Support Topics Documentation Slack YouTube Blog

Backendless Dashboard broken. Cannot access tables data


(Jonathan ) #1

There is some internal Backendless problem that has been preventing us from accessing our data tables.

Backendless dashboard is showing an internal ticket number of FECA829A-0F72-56D6-FF84-95DAD32CDD00

It occurred after trying to import some data from a CSV. I don’t need to import the data but I do need to access the data tables in the dashboard.

Can someone please look at this?


(Mark Piller) #2

Please let us know what actions in console result in the error.

Regards,
Mark


(Jonathan ) #3

I just launch the console in my browser go to that App and click on a table like “Activity", none of my objects show up but what shows up is an error message saying “Backendless encountered an error while handling the request. An internal trouble ticket with ID 43AED76C-8D7C-275F-FFB5-BF2F17EE6900 has been created and we will be investigating the issue.”

looks like a new id is generated every time i click on the table.

Tried on multiple browsers and same issue.


(Mark Piller) #4

Thanks. Yes, I see that some tables result in internal error. Presumably these are the tables which got created as a result of the CSV import? We will look into it as soon as possible.

Mark


(Sergey Chupov) #5

Hello Jonathan,
Looks like some relation data has been lost because of the import, e.g. I see no relations between Activity and Users table, though the database says there’s a column.
Can you please provide us the CSV file you did an import with so that we could try to identify the reason? Also, will it be OK if we restore the tables without relations? Otherwise we could try to restore the full data from backup, which is performed nightly as far as I know.


(Jonathan ) #6

Hi Sergey, I think it could have been that I was importing it and the users may not have been created on this environment. It would be fine if you could restore any corrupted tables without the relations. I just need to be able to access them so I can populate the data manually.

Thanks


(Sergey Chupov) #7

I’ve fixed your tables, now they’re accessible.
It would be great if you provided the CSV which caused the broken relations, so that we could try to find out the cause and fix it.


(Sergey Chupov) #8

Hi Jonathan,

Thank you very much for sending the export archive. I have inspected it and I see that the tables there only have relations between each other, not to any external presumably existing table, is it correct? If yes, then I guess such archive will be imported with no issues on my test app (I’ll check it anyway though), and that shouldn’t be a reason why the relations broke in your app.
Here are a few additional questions, answers to which might help the investigation:

  • Did any these tables exist when you started the import?
  • If yes, which columns (relations in the first place) did they have?
  • Were there any relations from other tables not present in the export archive (e.g. Users table) to one of them?

I think if any relations with these tables from CSV were already present in your app, importing these tables without those relation columns declared in CSV might have caused the problem we saw.


(Jonathan ) #9

I don’t believe any of the tables existed when I started the import.

And I believe the relations of the objects being imported didn’t have any relations to other objects except for the ownerId property. Their may have been some ownerId’s of users who were not created in that environment yet. I’m not sure what kind of problem that would cause.


(Sergey Chupov) #10

There definitely were a few relation columns, because cleaning the metadata about them was what fixed your schema. Probably you tried to create those relation columns after the import and that failed? Unfortunately I don’t remember exactly the names of all those relations (I think there were 3 or 4), but one of them was named “groups” and was related to Users table from one of Activity* tables.


(Jonathan ) #11

You’re probably right. Thanks for the assistance.