Backendless exception code :1054

No action was taken.

Thanks. I will try to reproduce your issue

I cannot reproduce your issue. The save method is working fine for me.
Can you please do the following:

  1. Create a new project
  2. Declare the class for the table you have a problem with (e.g. stockdata )
  3. Save the object of this class to the Backendless

Can you also provide the structure of your stockdata.class ?

The 1054 code informs that

Column %columnName% does not exist in table %tableName%.

You error looks like

BackendlessException{ code: ‘1054’, message: ‘Unknown column ‘udt.stockdata.stockatgodown’ in ‘field list’’…}

Do you have the column udt.stockdata.stockatgodown in the stockdata class?

Do you have the column udt.stockdata.stockatgodown in the stockdata class?


Yesterday it was for another table and error message was
BackendlessException{ code: ‘1054’, message: ‘Unknown column ‘udt.employeestock.serialVersionUID’ in ‘field list’’, extendedData: ‘{}’, detail: ‘Unknown column ‘udt.employeestock.serialVersionUID’ in ‘field list’’ }
at com.backend

I don’t have these fields. You can login and check all the data in my table. I am having trouble setting up new project. Could you guys try that out from your side? My application was working fine. Its just since from a day or two i am starting to see this error. Please help.

One more notice: the 1054 error is thrown when you try to find the objects with non-existed properties:

So check your project for the following code:

DataQueryBuilder queryBuilder = DataQueryBuilder.create();
queryBuilder.addProperties( "NON_EXISTED_PROPERTY" );
Backendless.Data.of( "TableName" ).find( queryBuilder );

Ok. But my query is fine and was working earlier. Btw did you guys delete the employeestock table from the database? I cant see it. Also when i login to backendless, its very slow and becomes unresponsive on the main page. This issue also from 1-2 days.

No we didnt apply any changes to your database.

Is it become slow only on the main page?

Main Page and especially when i select data option on the left pane.

Ok. So one of my table just vanished. Luckily i have data from yesterday which i am going to import now. I will check and update if same issue persists.

I cannot spot it. The tables data is paginated and should not slow the page.

I noticed that the backendless started reflecting my string value datatype i.e. ‘02/2020’ as Feb-20 in my stockdata table recently. I deleted and imported again. Its showing me as string again but why was it showing as feb-2020 earlier? Again, this happened recently only. My datatype is string, my input is also string. Also, the two table causing me issues have these fields. The first table (employeestock) is behaving properly now.

Normal updating of data of stockdata isn’t working. I checked different activities which was updating stockdata table. One of them doesn’t throw any error but doesn’t update the values as well.

Hi, @Pranav_Patel
Can you please describe the steps you go through to get this error (do you update single/multiple rows in one query; what is objectId of updated row and what is new data you’re trying to save; is your environment in browser or in API, what were you using)?

It will be useful


I am retrieving the data from the stockdata table and showing it to user. The user can then select either one object or several and input new values for them. Depending on that, either single or multiple rows are updated. In my stockdata table, i am trying to update the remaining and remainingatgodown/remainingatho field as per the user entry.
I have tried updating only one row also, it gives me the same error. I am testing all this on my android device.(API)

This issue was affecting another table employeestock yesterday. It started functioning properly automatically.
I am attaching a sample code. This class is used to update multiple tables. I have added comment “Yesterdays Error” & “Todays Error”. Yesterday error was resolved automatically and Maksym told me no action was taken to resolve it. I only updated android studio and didn’t make any changes to my code as it was working earlier. So its a bit strange that the error was resolved automatically and now i am having similar error in another table.SAMPLE.txt (10.1 KB)

I was told that error 1054 could be because of the query i am running.

This is my query. You can find it in the sample.txt.
stockclause = “batchno = '”+batch+"’ && type = ‘"+type+"’ && product =’"+product+"’";
stockquery = DataQueryBuilder.create();
This query will yield always one result only. And i am updating that one record.

I don’t see any issue with this and as I said, earlier it was working just fine.

@Pranav_Patel please provide the value of the ‘empsave’ variable in the row with ‘//YESTERDAY ERROR’ comment before saving

Sorry the yesterday error was when i was updating, not for the new empsave.
SAMPLE.txt (10.1 KB)

But that isn’t causing any issues now. Now the issue is

Backendless.Persistence.of(stockdata.class).save(finalsavestockdata.get(0)); //TODAYS ERROR

finalsavestockdata contain one row with the retrieved fields and values. Then i update these three fields

and i save it
Backendless.Persistence.of(stockdata.class).save(finalsavestockdata.get(0)); //TODAYS ERROR

Take any integer for all these fields to test. Only updating these 3 field values

From your side, could you try retrieving any row from stockdata table using these three field product, batch and type as a parameter in your query and try to update its remaining value. I think that will recreate the issue

Everything works fine for me.
My code is below and it does the job:
var queryBuilder = Backendless.Data.QueryBuilder.create()
var batch = ‘SL20-090’
var type = ‘Product’
var product = ‘SUJAL FORTE (300ml)’
var stockclause = ‘batchno = ‘’ + batch + ‘’ && type = ‘’ + type + ‘’ && product = ‘’ + product + ‘’’

var data = Backendless.Data.of('stockdata').find(queryBuilder)
  .then(finalsavestockdata => {
      if (finalsavestockdata.length > 0) {
      const firstItem = finalsavestockdata[0]


  .catch(err => {
    console.error('stockdata err: ', err)

It increments this 3 properties as it should. But it’s in my app with your table imported. This error possibly can depend on your concrete app. Can you add 1 test row that you’ll be ok if I update it?

I have added product Testproduct. You can try and update it.