Backendless flutter sdk doesn't support flutter 2

After upgrading my app to flutter 2.
now Backendless package isn’t compatible with the new flutter version, it doesn’t support null safety.

error occurred:

Because myapp depends on backendless_sdk ^6.3.0 which depends on http ^0.12.1, http ^0.12.1 is required.
So, because myapp depends on http ^0.13.1, version solving failed.
pub get failed (1; So, because myapp depends on http ^0.13.1, version solving failed.)

Try changing the dependency of your app to http ^0.12.1

http ^0.12.1 doesn’t support null safety, besides if i want to downgrade http package to 0.12.1 this will cause an error with other packages that use http ^0.13.1. all packages that are compatible with flutter 2, are using http ^0.13.1.

I see. Unfortunately, with the current implementation it won’t work then

Hi @adel_kasno

We have released new Flutter SDK v.7.0.0 with Flutter 2 and null safety support. Check it out!

Best Regards,

1 Like