Support Topics Documentation Slack YouTube Blog

Backendless Standalone - URL returned from File Upload contains the loop back address


(Roy N.) #1

I have the Backendless Standalone server installed on a CentOS v6.7 - 32-bit machine.

I am uploading a file via the File Upload API using REST and the returned URL is the loop address plus instead of the IP address of the Standalone server. I have no problems with uploading the file(s) but when I use the REST File download API with the returned URL from the File Upload API call, the call fails.

Is there a configuration setting that needs to be update on the Standalone server?


(Sergey Chupov) #2

Hi Roy,

Please provide an example of the URL you receive in response.


(Roy N.) #3

The URL returned from the File Upload API for REST is:

http://127.0.0.1:80/api/8cdb…/v1/files/test/file1.dat


(Roy N.) #4

Additional information from inspecting the various log files.

TaskManager - [WEBORB_ERROR] unable to find weborb-acl.xml. make sure… file is in WEB-INF
CodeRunner - [ERROR] Unable to set localhost. This prevents creation of a GUID.
PlayServer - [ERROR] weborb - [WEBORB_ERROR] unable to find weborb-acl.xml. make sure… file is in WEB-INF

The file POSTS using the File upload API succeeds but the response from the POST contains a URL with http://127.0.0.1:80/api/8cdb…/v1/files/test/file2.dat

I’ve tried stopping all the services and restarting them. Also a reboot but still the same problem. Help?


(Roy N.) #5

Are there any configuration files for the backendless server that I can modify to get this working again?


(Sergey Chupov) #6

Please look into htdocs/conf/backendless.config file whether in contains a loopback address somewhere.