Support Topics Documentation Slack YouTube Blog

Backendless Transaction suddenly not work

I just see a notice of Backendless 6.0 is live.
I test my app that uses backendless unit of work API, and suddenly everything is not working.
What happened? It worked well until backendless 6.0 announcement.

What SDK do you use?
What plan is your app on?

Android SDK.
Cloud 9 plan.
I think its not related.
Previously the app works very well.
The unit of work API I used just not work since there is nothing added to the database.

Make sure to update the SDK version. The latest one is 6.0.

What error are you getting?

No error.
Just all operations wrapped within unit of work are not executed. But it returns success.

How do i upgrade anyway? The latest one for android is 5.7.0 when I check the release history.

I am sure this is due to changes in your transaction API. Other operations outside transaction worked well.
This is disappointing.

How many operations do you put into a transaction?

We released 6.0 a few hours ago, the site is being updated, which included release history. The central maven repository shows there is new version of SDK for Android.

There are approximately 4-5 operations.
But Mark, I think this is not an issue since previously (before Backendless 6.0 announcement) everything run smooth.

It would be very disappointing if the transaction API can not be used/experiencing technical issues for several days. Since I need to demo it as soon as possible to my client.

Let’s stay calm and have the engineers look into the issue, okay? :slight_smile:

meanwhile, please update the SDK to 6.0 and try again

Okay. Hope that the problem is fixed asap:(

The maven central still states 5.7.1.
Can you post the sdk version such as “implementation com.backendless.” here instead?

I would need you to confirm that the problem still exists after you update the SDK. Could you do that please? You started using the functionality before it was released. Now it is available and now using 6.0 SDK is required in order to use transactions. So please update the SDK and let us know if it works.
As for Maven this is what I see:

And here’s the link:
https://search.maven.org/artifact/com.backendless/backendless

https://search.maven.org/artifact/com.backendless/backendless/6.0.0/jar

We verified that transactions work with the 6.0 version of the SDK. With the version you’re using they will not work as there are a lot of changes on the backend. Once you update the SDK, things should be back to normal.

Regards,
Mark

I cant compile the app.
Are you using methodhandle invoke or something like that?
Because there is an error when i tried to build the apk.
Only android O and higher can support this.

You should refrain from using higher level API as there might be apps are supporting lower sdk/api version. My apps minimum version is API 21, but your sdk version preventing me from building the app due to it requires API 26.