Support Topics Documentation Slack YouTube Blog

Backendless v3.x (update on today's maintenance)

Hey guys,

I’d like to give you an update on the scheduled maintenance we were performing today with version 3.x of Backendless. Most of you are not familiar with 3.x and if you’re using the latest version of Backendless, you can safely disregard this post. However, if you’re still on 3.x, please read on.

The general task we wanted to accomplish is to migrate the Backendless Stack and your data from the current data center to the new one where we have more control over the hardware, architecture, networking setup, etc. The new setup is designed to provide better performance and higher reliability.

Of course, migrating data, files and redirecting traffic for multiple live applications is not a simple task. As a result, we needed to have a window of time when we could perform the migration. Unfortunately, after multiple rehearsals, some things didn’t go according to plan. As some of you have noticed, some data was missing as a result of the migration. Since we were already outside of the scheduled maintenance window, we had to reverse the changes. It is quite disappointing since we had high hopes to get it over with today. I sincerely apologize for the difficulties you had experienced. We made all the necessary changes and will need to perform this routine again. We will work through the analytics data to determine a window of time when there is minimal traffic to minimize the impact. There will be an email announcing the next maintenance period.

Thank you for your understanding and support. Please reach out to me directly if you have any questions.

Regards,
Mark

1 Like

Hi @mark-piller,

Thanks a lot for the details on the issue, really appreciate for clarifying what went down with the update. While there were issues with the data center migration, I am not completely sure about this being only 3.x version issue, maybe you will be able to clarify.

Today I noticed a few issues: delayed login using JS SDK (version 5.4.3), login time-out responses on BackendlesSwift SDK (pod version: 5.5.5), and also issues on the Backendless dashboard (develop.backendless.com). I was under the assumption we are on the ‘latest’ version and should have not been affected by this update. If this update was supposed to affect only the 3.x version, and it means our project is still on 3.x version, where could I find more info on how to migrate to the latest?

Thank you,
Justinas

Hi Justinas,

If you’re using 5.x version of the SDKs, then the backend is also on version 5 (the latest). You can see the version of the current deployment when you hover the mouse pointer over the backendless logo in console.

Migration of the 5.x apps to the new data center went much smoother. The database architecture in v5 is not as monolithic as in 3.x and, as a result, we can migrate the 5.x apps individually rather than as a whole as it is in the 3.x case.

If you still experience any issues with your app, please open a new topic for each issue, and we will be happy to look into it.

Regards,
Mark

Hi Mark,

Ah, I now understand you have been updating both, 3.x and 5.x versions, it make sense now, thanks.

Mark.

We have a serious problem which started at 10:46 GMT on December 18th and still continues to occur. We have a Java application which is using 4.0.0 of the backendless SDK which performs a connection to backendless. This application has been running perfectly in production for many years but all of a sudden has stopped working in our production/uat/test/dev environments. The exception extract is the following:

org.apache.catalina.core.StandardWrapperValve invoke
SEVERE: Servlet.service() for servlet [DispatcherServlet] in context with path [/portalwebapi##1.0.8] threw exception [Request processing failed; nested exception is BackendlessException{ code: ‘Internal client exception’, message: ‘Received fatal alert: handshake_failure’ }] with root cause
BackendlessException{ code: ‘Internal client exception’, message: ‘Received fatal alert: handshake_failure’ }

It appears that our application cannot make a remote connection to backendless servers. We have done a low level network trace and confirm the same error.

Please can you confirm if there has been any change at your end which would prevent this from happening. Anything SSL/Certificate related perhaps? Our app id is 2D7A90CF-1EF4-11A4-FF49-84D0177DA900.

This is a real serious problem which has occurred at the same time as your outage.

Look forward to hearing from you soon.

Steven

@Steven_Salmon we do not change any certificate. The only thing that was changed is the server where application hosts, so public ip was changed. But the certificate was not changed.

Sergey you said “so public ip was changed”. Does this mean:

  1. 66.114.116.4 is incorrect?
  2. Does the SDK need updating to something later than 4.0.0 for this to be corrected?

@Steven_Salmon

  1. 66.114.116.4 is correct for now, but it can be changed in feature, so you should use domain
  2. no, sdk should work as well

@Steven_Salmon we have found issue with ssl certificate that can be reproduced only with old OS for example windows 7. We have fixed it, and may be it will fix your issue

1 Like

Thank you team. This has resolved our issue.