"Can not render page due to error"


Two of my users have been reporting a similar issue, for which I manage to get very little info. Could you help understand what is going wrong ?

It would help if the error message were displayed fully in a mobile form factor, but it isn’t the case. This happened twice on Android (built with the Native Mobile App Shell), not on iOS.

My App ID is D7075715-5086-625A-FFAB-39C2F40FB200

I just received a third feedback that was similar. All three occurred right after an update. Would there perhaps be a change in the SDK that would change user tokens, users being able to read AppData, or the like ?

Hello, @Nicolas_REMY.

Could you please provide steps to reproduce. And also create an archive with the published application so that I can run it.

Best Regards, Nikita.

Hi @Nikita_Fedorishchev ,

Honestly, I was about to tell you that I didn’t really know what caused the issue and how I could reproduce, because these errors have been reported by users.

However, “by chance”, I encountered the same error on my computer, while developing.

My app ID is D7075715-5086-625A-FFAB-39C2F40FB200.

Of course I went to have a look at the user in the database. I can’t see anything wrong with it. The user status is not Disabled.

So I immediately published the app in a folder, and created archives of that folder and of the UI builder container itself. Both archives can be found in the /render-error folder of my app.

To reproduce, I believe you would just need to launch the index.html with :

  • the same Local Storage, which reads :
  • the same session cookie, which is :

In fact, clearing the session cookie or restoring it didn’t do anything. However, clearing the Local Storage re-enabled the app, although in an unlogged state. And restoring the Local Storage reproduced the error. So my guess is that it’s coming from an issue in Local Storage.

Side note : it would be helpful that on this error screen, there could be perhaps a button which would reset the cookies and local storage. This way, users could at least resume using the app. Otherwise, on a mobile app, I find myself explaining to users that the workaround is to uninstall and reinstall the app. Not very user-friendly !

Side note 2 : is there a place where I can see the active user sessions ? I didn’t manage to find this, and it would help in understanding.

Hi @Nicolas_REMY ,

It looks like user auth token is not passed when you query user by ID. I tried to make the same request if your app without authentication and got the same error. From your screenshot it is not clear if header with user token was passed since “Request Headers” section is cropped.
I also tried to open your published app with preconditions provided by you. Page loaded and returned error about session timeout which was expected since the user token expired. This error tells me that user token read correctly from the cookie.
Which page you tried to open when you encountered that error? What code does that page uses to load current user by its ID?

Regards, Andriy