Cannot import openapi/swagger json: "This is not a valid service description"

I’m trying to create an API service via importing a swagger.json file, though I only get an error whenever I try to do so:

This is not a valid service description: 'file:/tmp/playtemp1832683365430314849/multipartBody12670871807927088129asTemporaryFile'.

I’ve tried multiple swagger files to test if it was just the file I was trying to import, but always leads to the same error. (For example). This is my first time trying to upload an API service in this way so I am not sure if this is something I’m doing incorrectly or not.

Thank you in advance,


Hi, @Nathan_Cousins

To give you a clearer idea of how the imported file should look like, I suggest you create a service in the Business Logic section, for example a sample “shopping cart” service. And export it as swagger document, you can do it by clicking on “Generate API Docs” icon near the created service. After the export, pay attention to the data you exported and compare it with the one you want to import. If you still have problems with importing the file, please contact us.