Support Topics Documentation Slack YouTube Blog

Cannot upload folders

I have an app on shared cloud. id 4BAEABFC-6FEF-EB39-FFE3-162B0D48F300
in developer console, files section, I’m trying to upload folder, by dragging it from local machine, but when I do so, nothing uploads and I see error in browser console “bundle.fe8f8300.js:1 Uncaught TypeError: Cannot read property ‘includes’ of undefined”. Please fix, I have many files/folders it would be quite tedious to upload it one by one

Hello @yuriy

You can archive your folder locally and then upload it as a single file, and finally unzip it in the FilesBrowser

Regards, Vlad

We’ve fixed it and add the ability to upload a directory through drag&drop, once it is verified by our QA department we will release it.

Regards, Vlad

interesting workaround, thanks!
Not 100% working though, I tried 100mb zip - after few hours I see no resulting folder.
Also needed some manual work still. Since it’s unzipping in the folder with the name of the file, and I needed folders in root directory, so I had to manually create 10 files for 10 folders in root. But it’s better to upload one by one anyway.