can't access Log management panel in console

When I’m trying to open Log Management panel
(url becoming
I see error “User has no permission to create entity” no data in panel are loading. In browser debug console I see error
GET 403 (Forbidden)
with message {“code”:9000,“message”:“Wrong application id provided”} when I looked at this url.
I tried at different browsers with same result. I have another app on same account - it opens Log management without any error.

Also, maybe it’s important maybe not:
I was registered in backendless with google account, a few days ago I
changed password (in backendless settings), after that I experienced
difficulties with login and short session time-outs. Maybe error is because of that.

I suspect you restricted API access for the NotAuthenticatedUser role. Try to enable all operations for that role, then navigate to the Log Management screen (some things will happen on the backend) and then you can trim down access for that role.

Thanks Mark.
Interesting. Yes I had disabled on global level all access to all roles.
I enabled back NotAuthenticated role and tried log management - same error.
Enabled back a Authenticated and ServerCode - same error.
Enabled back Rest - aha, then it worked!
So, after that I can make all roles disabled again or backendless management won’t work properly?

Hi Yuriy,

You can disable all access for NotAuthenticatedUser and RestUser, but you will need to make one change in the permissions for the Loggers table that will be required so you can access the Log Management screen. Please see the screenshot below:</img>

The reason for this is the “Loggers” table is special. We tried a new approach where we use Backendless itself internally for data storage. The logging functionality is built-in and instead of creating an internal table that is not visible for the developers, we used Backendless API itself to store data about the loggers. The permissions was an oversight that came up later on. This is something we plan to handle, so devs like you do not need to jump through the hoops to configure security.


Thanks. I guess the same is happening with BIConfigurationItem table used in Database Function Pack, ?