Can't delete application

Application ID: 1D19D3EE-66A1-04F4-FFC4-4C40AB226D00
Error UID: 48352921-7F6C-8E66-FF3F-2ED7C1239300

Backendless encountered an error while handling the request. An internal trouble ticket with ID 48352921-7F6C-8E66-FF3F-2ED7C1239300 has been created and we will be investigating the issue.
RedisClusterConnectionPoolcan not create connection for direct cluster node [63245be3df501de08da982d24acf700c2ab5cb49].
java.lang.RuntimeException: RedisClusterConnectionPoolcan not create connection for direct cluster node [63245be3df501de08da982d24acf700c2ab5cb49].
	at com.backendless.lettuce.cluster.RedisClusterConnectionPool.getConnectionToPartitionBySlot(
	at com.backendless.lettuce.LettuceUtil.lambda$deleteKeysByPattern$0(
	at com.backendless.lettuce.LettuceUtil.deleteKeysByPattern(
	at com.backendless.lettuce.LettuceUtil.deleteKeysByPattern(
	at com.backendless.lettuce.LettuceUtil.deleteKeysByPattern(
	at controllers.console.MyApplication.lambda$deleteApplication$6(
	at com.backendless.async.BackendlessExecutorService.lambda$submit$0(
	at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(
	at java.base/java.util.concurrent.ThreadPoolExecutor$
	at java.base/
Caused by: io.lettuce.core.RedisConnectionException: Unable to connect to<unresolved>:6379
	at io.lettuce.core.RedisConnectionException.create(
	at io.lettuce.core.RedisConnectionException.create(
	at io.lettuce.core.cluster.PooledClusterConnectionProvider.getConnection(
	at io.lettuce.core.cluster.PooledClusterConnectionProvider.getConnection(
	at io.lettuce.core.cluster.StatefulRedisClusterConnectionImpl.getConnection(
	at io.lettuce.core.cluster.api.StatefulRedisClusterCo

Problem description

I tried to delete the application but it throws the above error.

It is similar to previous errors posted in the forum however there was no solution there. Can you please help?

Steps to reproduce

Please describe steps to reproduce starting from the first action.

  1. Click Delete application in the console
  2. Type DELETE app_name

Hi. We are working on it already.
I cannot promise that it will be solved today, but I may delete you app manually if the fix is ​​delayed.

Hi Oleg,

I just tried again and the app was successfully deleted. Thanks for your help. Is there any reason you found why it wouldn’t work so I can avoid a repeat?


It was our internal problem with one of our services. Automatic recovery hadn’t worked and required human intervention.