Can't fetch 'App table' objects in Testflight

So my application has few custom classes which works perfectly in Xcode. I can fetch/update/delete these objects and also I can use the system generated classes like User perfectly.
When I wanted to push this app to my testers. They were not able to fetch any of the objects created by me. Although they could log in and access the properties in their User table (like profile image). I have a search query, which searches for users, which also is functional.
Can someone please tell me why I can’t fetch my objects in test flight, while its perfectly fine in Xcode?
I have seen someone’s post in this forum saying to change the Product Name to the name of the application, I tried that but it still won’t work.
Really need to fix this urgently. Thanks!

Okay, I fixed the issue, it was the same. I renamed the “Product Name” to something other than my App name. This solved the issue. :slight_smile:

PS: Target>Build Settings > Packaging > Product Name