Cloud Code - Timer - Failed to run?

I have a timer that is supposed to run every Friday at 20:00 GMT -

Last Friday, it failed to run -


Any ideas?


We have an issue with logging of timer invocations. And we are already working on it.
The timers itself work properly. E.g., in order to confirm or refute it invocation you can use the Backendless Data service (until we make a fix).

In this case, the timer did not run.


How did you track that the timer wasn’t called in a specified time?

The timer sends a weekly summary email that was not received.


I can not affirm for sure, but couldn’t it be a problem with the sending report or its generation?
Why I ask, because all the timers of all apps work in the same manner on the same code, and if the problem was here, it would be noticeable. Thus I supposed that the cause could be somewhere in the calls chain.

It could be, but after I noticed we didn’t receive the report, I manually ran the timer, and it worked.

  1. The timer doesn’t show a run
  2. I didn’t get the email that is the outcome of the timer run
  3. I got the email when I ran the timer manually.

The evidence points to the timer not running, but it could be possible it ran, wasn’t logged, and failed. However, that second scenario feels very unlikely.


Did you try to switch the timer off and switch it on again?


Hello Tim,

Please try to switch the timer off and then on as Oleg said. Let us know if it helped.

I toggled the timer off and back on. It runs once a week on Friday, so I won’t know until tomorrow.


Please let us know tomorrow, if it worked.

Hello @Tim_Jones

We’ve just updated cloud servers with a fix for the issue you described above. Could you kindly let us know whether fix works for you well?


Hi @Inna_Shkolnaya

My timers were working fine until this week. They stopped working but are now working again.