Code Runner Properties Allowed Host not allowed

Hi guys,

I have a problem with allowedHosts. I set them to allow, but the app still give me error “access denied resolve”. I have added in the External Host, but still get this error message. Any ideas?

Thanks, Victor.

enterprise.allowedHosts =,\,\,\

Hi Victor,

Could you please describe your use case? Do you use Online or Enterprise version?



Hi Denys,

I think it’s using Enterprise (standalone) now.


Try to add external host as described here:

I did already, as shown in screenshot.

The problem still the same.

Internal ticked has been created for this issue.



Thanks for your help, Denys.

Hi Victor.
First of all, we don’t provide free support for standalone version.

About your problem:
For standalone version you need set up cached DNS, to get the same dns-answer on the same dns-request. Because inner cache refreshed every 3 minutes, you may get inconsistence behavior during this time period if the host’s ip changed.
In future we’ll remove this restriction for standalone version.

p.s. It is no need to set port in file - just hostname.