CODELESS losing blocks! help

After 2 hours of working with codeless I just lost all the blocks except one was left!!!
I wrote blocks that would create records and set relations to 4-5 tables, and managed to make it all work nicely buton the final step when I draged a new Save object block everything else vanished! This is crazy!

I did not deployed to server and i tried to reload the page, login log out , no luck, I am left with one block out of maybe 10 !

Any ideas what is going on?

I had a look at the localStorage and I’ve saved whatever was in the BACKENDLESS_CODELESS_BL key. See attached file. Can my blocks be restored from this or are they completley gone?

Application ID is E27B10A2-C4B9-A5A6-FF6A-AB65CBE35A00BACKENDLESS_CODELESS_BL_E27B10A2-C4B9-A5A6-FF6A-AB65CBE35A00.txt (413.0 KB)


Hello @Constantin_Craciunescu

Have you tried to use “Change Log” ? It should help you to roll back your logic

Regards, Vlad

Oh wow, ChageLog did it, I was able to restore to a previous state! Thank you

Any ideas why that happened or what should we be aware of when working with block? All I did was to drag an object like I did for the last couple hours. Is working with codeless blocks that sensitive procedure?

Thanks again

No, there are not any specific/sensitive actions, but unfortunately, it happens time to time and we do our the best to fix this problem in the Codeless

It’s a great feature though
Thanks again for your help

My pleasure!