Support Topics Documentation Slack YouTube Blog

Codeless service fanished

i was working on a codeless service and doing some test.

suddenly i hit test again and got the error “service not found”
when i refreshed the page the service was not there anymore :frowning:

the service and its methods are not there.

app id 07D0CC0C-4A50-198B-FFFB-78866CCD9600

from the log:

2019-08-08 15:05:54,980 | SERVER_CODE | INFO | [14379] [ANALYSE CODE] codePath: /var/lib/backendless/repo/07d0cc0c-4a50-198b-fffb-78866ccd9600/files/servercode/CODELESS/Store/DRAFT
2019-08-08 15:05:54,982 | SERVER_CODE | INFO | [14379] Building Model…
2019-08-08 15:05:54,991 | SERVER_CODE | INFO | [14379] ServerCode Model built in 9ms
2019-08-08 15:05:54,992 | SERVER_CODE | INFO | [14379] Errors (1):
2019-08-08 15:05:54,992 | SERVER_CODE | INFO | [14379] Unexpected reserved word (services/Store/index.js:77)
2019-08-08 15:05:54,994 | SERVER_CODE | INFO | [14379] Processing finished in 25.902ms

Hey
Im sorry but my work is at hold until i get the lost service back.
Is there any faster way to reach out?

Hi, Mohammad.

All the changes are stored on the client, before you pull it to the server,
so if you didn’t save it yet, it won’t be too tough to restore it to the latest saved version

and also I have a few questions:

  • Did you save/deploy the missed/broken Codeless logic?
  • Could you open Backendless Dev Console in “incognito mode - cmd + shift + N” and see if your Codeless Logic is still there
  • there was one specific logic (API Service, Event Handler, Custom Function, …) or there ware a lot of BL items?
  • Can you provide us steps to reproduce the problem?

Regards,
Andrew.

the service methods are deployed more than ones for sure (i have been working on them for days)

1- Yes
2- im not sure i understand this one. i did press ctrl+shift+n and the browser said im in incognito mode. then i logged in normally and the service is still not there.
3- Yes one service called “Store” and the method that i was working on named “AutoAddStores”
4- i don’t remember what was the last block that i added or changed. all i remember that i was testing with the blocked and deploying then running a test. then the service is not available anymore.

i was searching in the files and i found the service in servercode -> CODELESS folder and i can see the xml file for the blocks. can i use that to retrieve my lost service?

Hi Mohammad,

Our engineer will need to look into this. Somehow the logic you added resulted in invalid code generated for it. I created an internal ticket to investigate the issue.

Regards,
Mark

For the reference the internal ticket number is BKNDLSS-19320

Thanks mark!
i hope this get fixed so i can continue.

loving codeless btw

found the issue after you guys restored the service.(thank you)

enabling these two blocks cause the issue.
Untitled

Hi Mohammad
The issue has been fixed and will be released asap
Regards, Vlad

Hey @mohammad_altoiher

We’ve just updated our cloud servers with a fix for you. Please verify whether everything works fine now

Anton

@anton-govorushkin
i tried it and my service method are gone. and i couldn’t even retrieve it like i did before by disabling blocks

Hi Mohammad,
could you check it please one more time, for regenerating code needed to move any block and only then click at DeployModel button
Regards, Vlad

Hey
its working great now!
thank you very much