Support Topics Documentation Slack YouTube Blog

Connection problem during deployment

Hello!

I see permanent connection problems during custom code deployment (via “npm run deploy”). The error message:

20:32:59.641 Publishing Model to server
20:37:03.572 Error: Unable to publish model. No connection with server

Meanwhile, “npm run debug” works. App ID: 7D0CA196-6BFB-3B9F-FF01-EBB42A286700

Hi @andrey-olishchuk

I able to reproduce the problem and it seems it’s related to the size of your Business Logic.
I’ve created an internal ticket BKNDLSS-20586 and we are going to fix it asap

Regards, Vlad

@andrey-olishchuk we have fixed the issue

It is still not possible to upload the code (with no significant changes). And now the project looks broken and we can’t fix it because we can’t upload even previous version. Which limits are reached? Thank you!

UPD: I have tried to deploy some different versions from last year (they definitely was deployed previously) but even they could not be deployed now.

UPD2: Or maybe 504 during deployment does not matter and code still is deployed? Because I have 504 but see that something was changed in the Backendless custom code UI.

Hi @andrey-olishchuk!

I have tried to deploy your business logic to test app. During deploy I got error about missing dependencies:

11:33:52.016 Cannot find module ‘graphql’ (services/graphql.js)
11:33:52.016 Cannot find module ‘graphql-tools’ (services/schema.js)

Can you send me in direct messages archive with business logic that you tried to deploy?

Regards, Andriy

Yes, that is broken business logic which could not be changed, because we cannot deploy any working version. I have sent a zip in direct message.

Thank you!

Hi @andrey-olishchuk!

I reproduced your problem with BL that you had send me. In my case during deploy I got “504 Gateway Time-out” but logic was deployed. You can check progress of deployment process by looking at the logs in “Files” service under “logging” directory.
I have reopened internal ticket BKNDLSS-20586 for this issue. We let you know when it will be fixed.

Regards, Andriy

@andrey-olishchuk the issue is fixed I was able to deploy your project

Thank you! Now I see “successfully published”