Support Topics Documentation Slack YouTube Blog

Currently the database is being modified by operation: IMPORT - what to do?

Hi, I’m facing an issue “Currently the database is being modified by operation: IMPORT” each time I’m trying to modify any table in my DB

Recently I have run the import. It was completed 25 minutes ago. After that I go an error.

1 18:45:49 IMPORT_DATA Importing Started.
2 18:45:49 IMPORT_DATA Preparing files to import
3 18:45:49 IMPORT_DATA Copying of DeviceRegistration.csv, size: 0.006 MiB.
4 18:45:49 IMPORT_DATA Creating temporary tables
5 18:45:50 IMPORT_DATA Creating user’s tables
6 18:45:50 IMPORT_DATA Preparing DeviceRegistration table: initializing columns.
7 18:45:50 IMPORT_DATA Preparing DeviceRegistration table: updating column related IDs.
8 18:45:50 IMPORT_DATA Preparing DeviceRegistration table: initializing relations.
9 18:45:50 IMPORT_DATA Checking denied and duplicate columns.
10 18:45:50 IMPORT_DATA Resolving related table.
11 18:45:50 IMPORT_DATA Getting meta-info about insetable tables.
12 18:45:50 IMPORT_DATA Start import table: DeviceRegistration
13 18:45:50 IMPORT_DATA Creating DeviceRegistration channel ‘default’.
14 18:45:52 IMPORT_DATA Table ‘DeviceRegistration’ was imported at 2 seconds. Saved 22 records.
15 18:45:52 IMPORT_DATA Finish import table: DeviceRegistration
16 18:45:53 IMPORT_DATA Started restoring relations.
17 18:45:53 IMPORT_DATA Clearing user data table cache.
18 18:45:53 IMPORT_DATA Deleting temporary tables.
19 18:45:54 IMPORT_DATA Finishing pointers export.
20 18:45:54 IMPORT_DATA Restoring expiration tasks for DeviceRegistrations.
21 18:45:54 IMPORT_DATA Import finished.

Hello,

What is your application ID?
What table can we try to modify? And by “modify” do you mean adding data to it? Changing columns? Renaming the table?

Regards,
Mark

APPID = AE54889A-41B8-A5D2-FFBA-63E5EC5A2C00

Modify = schema change. Data change successfully occurs. Yes, changing columns

Which data table can we try modifying?

[Users] at the moment

Works now! Thanks

Again - the same issue. I guess [Users] table shouldn’t be updated using import. I’ve tried just to update schema for this table

Have you started another import?

yes :frowning:

Has the import finished?

yes, they are very short

The import will go away. We will look into why it doesn’t happen as soon as the import is finished.

Is there 1 hour timeout? Seems that I was waiting for an hour before I could continue db schema changing.

I apologize, I do not know how long the timeout is. The database is unlocked now.

Regards,
Mark

I get it. Please inform if any additional information is required to reproduce the issue. My issue has gone now. I have manually changed table schema as required.