Custom business logic sometimes not working


  1. Code stops working in production

I have an afterPublish handler on all the channels (*). When I deploy it in debug after each execution it throws a kind of SSL exception in the CodeRunner console, but when published it works just ok for a time.

After a time it stops working. I found out that it stops working after I access the Business Logic tab in the development console.

  1. Code does not run at all

I tried to add another handler (an afterCreate handler on a table) but it does not run at all. When I connect the remote debugger and place a breakpoint inside the method it does not hit that breakpoint.

Can you please help solving these two issues?



We will check this issue.



I have the same problem.
My script is running in debug, but when I publish, the script is not run or not enabled.
And I have “Successfully published” and enabled checked in Production
Can you help me please ? :slight_smile:


Could you please provide us your app id?


Hi Stanislav,

My id app is 11639CD7-93BD-B8E4-FF46-BC4D682F5D00
Thank you for your help

My scripts works in debug, if I left my command opened :smiley:

But if I deploy my scripts in production, nothing run
Something is wrong ? Is it necessary to create an API service for the execution of the script or is it ok without this ?

What type of CodeRunner do you use ?

Hi, I use the Msdos command to call npm run debug or deploy

Please, provide code example with which i can be able to reproduce described behaviour.
Because i have tried, and for me all works fine.
Maybe you make request to blocked external hosts or system calls ?
Try to make any simple action in your business logic code. Please, write the result.