Custom Domain - Subdomain Connection


I’m looking to connect my app to a subdomain. I’ve configured a the root domain before successfully, but when I try to link it up to the root domain subdirectory in cloudflare I’m getting an error.

The cloudflare CNAME subdomain seems to be set up correctly because when I go to that address it returns a response from backendless:

Any thoughts why this new subdomain can’t be connected? My application ID is: B46B9599-0927-5212-FF01-2D3539543E00

Thank you!

Hi @G1299

After changes in domain records, it may require up to one day, that the record is refreshed all over the world.
You can check it with different commands (depending on your OS):
host -t CNAME
dig -t CNAME

But keep in mind, that from different geographical locations you may receive different results.


Hello @G1299,

I’ve had this exact same problem because of using Cloudflare.

The way that I fixed it before for us was to turn off the Cloudflare “Proxied” switch for your new subdomain.

Then give it a few minutes and try to add your new subdomain again in Backendless.

After Backendless detects the changes and successfully is able to add the non-proxied subdomain to your app, you can go back to Cloudflare and turn the proxy back on again and it should all work.


Awesome, turning off the proxy in Cloudflare worked. Thank you both Viktor and Mike!

@G1299 | I’m glad I could help! :grinning:

Hi I’m also using Cloudflare (proxy off) and I am getting the same error. I can see that the CNAME exists from all kinds of sources, but the BE console keeps saying “Unable to find…” Is there a reason it would take BE longer to see the updates to a CNAME?

Hello @David_Thompson,

how long has it been since you set up CNAME?

It just took a long time to update with BE…other nslookups and other sites saw the changes, but BE just took longer. All good.