Custom functions not persisted in the UI Container and random errors kept appearing

We are getting the following errors in a specific UI Container.

I checked the custom fields one by one but I can’t figure out which one is missing or which one has these errors

The page with the errors is also live and the live version seems fine, the only problem is we can’t publish the container because of these errors.

Also, we keep on getting these errors randomly.

If someone could check, we’d greatly appreciate it. Thank you
App ID: 4A47197B-AE30-FA84-FF56-0071F4010900

Hello @DALDE_John

Due to an error, the function with id “bef11…” has disappeared.
Based on the defenition here

this is the “DSToffSet” function.
I see that the file name of the function has “(1)” at the end. Try to remove “(1)” then check error


It worked! Thank you so much :smiley:

May I also ask, what are the cause of the random errors?

Hello @DALDE_John!

I suspect that during the transfer of functions on 11/27/2023 (specifically, copying the file “ui-builder/containers/CS/functions/bef11ace8b017bd83146ea310b02611f” to “ui-builder/containers/Sales/functions”), the same directory was transferred twice.
This led to the renaming of the second instance to “bef11ace8b017bd83146ea310b02611f(1)”.
As for how the first directory was deleted, I’m unable to provide an answer.


@Alexander_Pavelko What I meant are these errors, do you have any idea about these as well?

It’s challenging for me to pinpoint the issue without more details.
Could you provide additional information, such as how frequently these errors occur?
Also, please add screenshots of the logic in the methods where the error appears.
Consider creating a test service/method to isolate the problematic logic, allowing for safe debugging without affecting your application.


This happens on almost all of our methods, timers, and handlers. I also can’t pinpoint when it happens as it happens very randomly.

My hunch is, it is happening when a method,timer or handler does a request. It happens when we get from Close, get from the DB, and also when we access our google sheets but it doesn’t happen everytime we do this, it happens very randomly.

If you could check my last screenshot, those are the ones that returned those errors at that time. The first one is a custom function while the other two in the bottom are timers.

For debugging, I isolated this logic in my sandbox. We usually use this when we are getting a lot of data from the DB, in this case, we are getting it from our ms_classes table. This logic is also present in our DatabaseUpdateMSClasses Timer which can be seen in my last screenshot with the errors

Here’s the API link of my sandbox -

Hello? Any updates with the above?

Hi @DALDE_John,
can you please double-check if the same error still appears? I received information from the team that a fix for this issue has already been made.


Hi @Sergey_Androsov,
We just received the same error today at 5:01 AM EDT


any updates with the above?
We are still getting these errors

More errors today @Alexander_Pavelko

Any updates on this error? It still keeps popping up randomly

Hello @DALDE_John

We apologize for any inconvenience this may have caused and appreciate your patience during this time.
Thank you for your understanding.

We are working on a solution to this issue, currently we cannot predict how much time it may take. As soon as the issue is resolved, we will definitely inform you in this thread additionally.


1 Like

Just adding another update. More errors are showing up today. Happened at around 5:30pm GMT+8