Custom Server code

The document available around Custom Server code appears to be out of date with what’s available on your website.
Can you please check and confirm

eg: the “Download Code” from console is not downloading something that can be opened in eclipse. Please advice.

You are correct - the zip file generated by Backendless does not include project file for Eclipse, however, there should be no problem at all for you to create an Eclipse project with the source code included into the zip.

Have you seen any other discrepancies?


Well I was able to build the project and then tried linking the coderunner to my application
minor documentation discrepancy: .sh file name is now and not (
When I started the script with my code runner secret, It still prompted me for application Id and Code Runner Secret

Please enter application ID and press [Enter]:

Please enter CodeRunner secret key and press [Enter]:

I then got following error

[ERROR] Unable to set localhost. This prevents creation of a GUID. Cause was: <redacted>: <redacted>: nodename nor servname provided, or not known <redacted>: <redacted>: nodename nor servname provided, or not known
	at ~[na:1.7.0_25]
	at net.sf.ehcache.Cache.<clinit>( ~[CodeRunner.jar:na]
	at net.sf.ehcache.config.ConfigurationHelper.createCache( ~[CodeRunner.jar:na]
	at net.sf.ehcache.config.ConfigurationHelper.createDefaultCache( ~[CodeRunner.jar:na]
	at net.sf.ehcache.CacheManager.configure( ~[CodeRunner.jar:na]
	at net.sf.ehcache.CacheManager.doInit( ~[CodeRunner.jar:na]
	at net.sf.ehcache.CacheManager.init( ~[CodeRunner.jar:na]
	at net.sf.ehcache.CacheManager.<init>( ~[CodeRunner.jar:na]
	at net.sf.ehcache.CacheManager.newInstance( ~[CodeRunner.jar:na]
	at net.sf.ehcache.CacheManager.newInstance( ~[CodeRunner.jar:na]
	at net.sf.ehcache.CacheManager.create( ~[CodeRunner.jar:na]
	at net.sf.ehcache.CacheManager.getInstance( ~[CodeRunner.jar:na]
	at com.backendless.coderunner.holder.CodeExecutorHolder.<init>( ~[CodeRunner.jar:na]
	at com.backendless.coderunner.holder.CodeExecutorHolder.<clinit>( ~[CodeRunner.jar:na]
	at com.backendless.coderunner.processor.MessageDispatcher.<clinit>( ~[CodeRunner.jar:na]
	at com.backendless.coderunner.processor.MessageProcessor.<init>( ~[CodeRunner.jar:na]
	at com.backendless.coderunner.processor.DebugMessageProcessor.<init>( ~[CodeRunner.jar:na]
	at com.backendless.coderunner.CodeRunner.loadMessageProcessors( ~[CodeRunner.jar:na]
	at com.backendless.coderunner.CodeRunnerLoader.main( ~[CodeRunner.jar:na]
Caused by: <redacted>: nodename nor servname provided, or not known
	at Method) ~[na:1.7.0_25]
	at$1.lookupAllHostAddr( ~[na:1.7.0_25]
	at ~[na:1.7.0_25]
	at ~[na:1.7.0_25]
	... 18 common frames omitted

I then saw following

Registering runner on: with secretKey: <redacted>

Runner successfully registered

Parsing event model...

Build successfully: EventModel{timers=0, eventHandlers=1}

Deploying model to server, and starting debug...

Model successfully deployed...

Waiting for events...

At this point, my application’s Business Logic > Debug tab was still not showing the events that should be available in debug model.

Also, when I created new record in the “OrderManagement” > “Order” table, I saw no logs on the console… However the data was successfully inserted in the table

Please let me know if I can provide any other information. For what I am planning to build, its quite important that I be able to write custom code… The only other choice would be to write my own backend application :frowning: