Data Table doesn't return any items


We use the data tables in the UI builder. One of our tables does not return anything at all, even though there are records in the table. I can see in the console that the call to /count returns 8, but the call to /find returns an empty array.

Hi @Christopher_Manzi ,

Have you changed any security permissions for the data table in question?


I checked the security settings. It seems like the users/role in question should have access to the table. Are there any security permissions in particular that could cause this?

Any role the current user has that denies data retrieval will result in this behavior. If you would like us to check that, please provide the following:

App id
Page name
Instructions how to get to the page (if anything other than just running it)

App id: 86DF97EF-A838-427E-A069-5F4DC2B95285
Page name: system → kitIds
Instructions: login and navigate using the ‘Manage Kitids’ button

Please provide test credentials that would demonstrate the problem

How should I provide those to you?

You can send me a DM here: Profile - mark-piller - Backendless Support

The internal ticket is BKNDLSS-26071

Is there any update on this? it is still not working.

Hi Chris,

Yes, we actually worked on it this week. Here are the changes we had to make to get it working, all of them are in the permissions area for tables and folders:

the KitIDs table columns visibility - this is what you currently have:

this is the change you should make:

Modify role permissions for the ui-builder/containers/system directory:

And one more for the ui-builder/containers/system/index.html file:

and a similar change for the ui-builder/library:

When we made these changes in an app cloned from yours, we got the data for table in question.

Please give it a try and let us know if it works.


That seems to have worked - thanks!