Date Picker Change Value null


I’m using a date picker change value for update the database but it’s coming empty maybe something new again please let me know how to use it now?

Screenshot 2023-04-20 at 17.39.10

I clicked and change the date value but not change go to empty and it’s undefined the “Change Value” when I ask for print or saved.
Thanks, Mario

Hi @Mario_Ghersi

I tried to reproduce the issue and seems it works well for me.
Could you please create a test empty page only with the component and check how it works.
btw, looking at the logic there should be 3 sync print

> Desde
> timestamp
> Save

but it the log I can’t see that

This is big sorry it’s not working! New page just a datePicker and a Text for the date and just default not working.

Changed Value = Undefined

Screenshot 2023-04-20 at 18.00.53

Never ad the date at the picker and this is new, how to do it?
It’s just a picker must shoe the date.

Thanks, Mario

do you link it using the data-binding approach or ChangeEventHandler?

Sorry I don’t know I’m using the codeless like the image and working OK from a log time until now.


could you please share a link to the page?

here is mine

OK, I try Incognito browser and it’s working with the issue of the format but at list working.

Screenshot 2023-04-20 at 18.14.14

Any idea how to solve it just clear cache and cookies?

it’s strange such a file should not be cached

but anyway, to reset I just open the browser dev tool and enable “disable cache” and then refresh

Ok clear cache was the solution for the test page.

But still not working for my old pages at the website running in production, with the same browser where it’s working OK. How to solve that ? Some thing change from you side to be in this problem?


I do not think the issue is with cache because when you publish your UI Container it creates new files and the server will return “no-cache” so the browser should apply/render new files

let’s try to investigate what/where exactly doesn’t work, could you please find these prints in your log

> Desde
> timestamp
> Save

OK the default it’s coming wrong for custom format:

The solution it’s change to MM/DD/YYYY HH:MM in each Date Picker or un my case DD/MM/YYYY HH:MM.

Thanks, Mario