Domain Control not working at all

Hi there,
I have a strange problem. I’ve put url of my website to Domain Control section in my app settings. I’ve tried all the formats (eg. / and even the IP address of the internal IP address of the website) but with no success. I still get the following error while trying to access to the parts of my website where the Backendless is used:
Fatal error: Uncaught exception ‘backendless\exception\BackendlessException’ with message ‘Backendless API return error: Wrong domain Error code:2010’ in /data/web/virtuals/133189/virtual/www/domains/blabla/backendless/src/lib/RequestBuilder.php:162 Stack trace: #0
/data/web/virtuals/133189/virtual/www/domains/blabla/backendless/src/lib/RequestBuilder.php(68): backendless\lib\RequestBuilder::handleError(Object(backendless\lib\HttpRequest)) #1 /data/web/virtuals/133189/virtual/www/domains/blabla/backendless/src/lib/RequestBuilder.php(41): backendless\lib\RequestBuilder::doRequestByUrl(‘https://api.bac…’, NULL, ‘GET’) #2 /data/web/virtuals/133189/virtual/www/domains/blabla/backendless/src/services/Persistence.php(208): backendless\lib\RequestBuilder::doRequest(‘data’, ‘Event?where=bla…’, NULL, ‘GET’) #3 /data/web/virtuals/133189/virtual/www/domains/blabla/events/index.php(27): backendless\services\Persistence->find(Object(backendless\services\persistence\BackendlessDataQuery)) #4 {main in/data/web/virtuals/133189/virtual/www/domains/blabla/backendless/src/lib/RequestBuilder.php on line 162

My App ID is: E00A57E6-2BFA-348C-FF9B-376E2E9A4500
Didn’t i miss something?
Thanks for a reply,

Hi Marek,

Please, make sure you’re adding an “Origin” header to your requests. An example can be found here:

Hey Sergey,

Thanks for your answer. I still can’t figure out, what should I do since I use PHP framework. Should I call addProp(“what should i put here?”)?

We’re currently investigating the work of Domain Control when using SDKs.

We shall notify you as soon as we have any results.

So if i use PHP/JavaScript, there is no way to set Domain Control security at the moment?

Yes, at the moment its work is unstable.

Okay, thank you.

And when do you expect it to release?

Can’t say yet, but I think it’ll take no less than a week. We can keep you informed here as the progress goes on.

Yes, please, keep me informed.