Email Notifictaions: Long SMTP User ID not being allowed

I use Postmark and an internal SMTP service for email notifications. In trying to setup Backendless messaging with the SMTP settings it will not allow me to use the lengthy 36 character dashed API key as the User ID. There seems to be some arbitrary limit or validation on the field that is preventing these from saving.
User ID: ea596fb2-ac12-1234-b567-8901cf12ea3e
Gives me an ‘Invalid User ID value.’ message on the field and will not save.

Hi Chris,
Please try to use your Postmark profile email instead of your API token.
Regards, Ilya

This solution does not work for either of our SMTP services. Both Postmark and our internal SMTP service that uses a similar API key style reject the credentials. What exactly are the validation conditions for this field? It seems to require an actual email address as the User ID, and then appears to then check to see if the credentials work before saving the settings.

Ok, it looks like there is a mistake in the validation of this field. Now it allows to set the only email but not user id.
I’ve created the ticket in our task tracker (BKNDLSS-12857).
It takes some time before it will be in production.
Regards Ilya.