Support Topics Documentation Slack YouTube Blog

Email Settings

I am receiving an error message when setting the email settings. The error message is username and password not accepted. I changed userID and password fields with a valid gmail account. I am setting the TLS option.
Email Settings


    SMTP Server:

    Port:

    From:

    User ID:

    Password:

    Security: SSL TLS

I just tried with my gmail account and it worked just fine. Can you post the values you’re setting (without the password of course)?

Mark

What I have discovered is that my password for the email did contain 1 or more special characters. I changed the email password to not contain any special characters and the Manage->App Settings->Email Settings works.

I then changed my email password back to one that does contain special characters and the Email Settings failed.

I then changed my email password to a password without special characters and it failed.

Need to know what the password rules are?

More investigation lead me to a sequence that i didn’t know about.

It turns out that you must enter the password and other email settings and select the Save button. Then
you can reliably use the Test button to test the settings.

Hi, Roy!
As shown in this doc https://support.google.com/accounts/answer/6010255 Google can block sign-in attempts to some apps while displaying “password incorrect error”. Following the steps in the previous ref you can “Turn on” account access for these apps here https://www.google.com/settings/security/lesssecureapps

Thanks for the info, I did have these google email settings set for less secure applications.

Yes, there is definitely something with password length/symbols. I wasn’t been able to successfully test email until I reduced password length to 10 symbols (alphanumeric only). I’d like to know more definitely about password cause I prefer to use strong (long with special symbols) pass. Google “Less secure” was switched ON also.

Hi Yuriy,

In order to help you, we need to reproduce the issue first. So if you have any password example, which would result in an error in some way - please create a dedicated support topic and we shall investigate it.

Thanks!

Tried to reproduce now - nope, seems working fine with old long password too. Maybe google “Less secure” setting required some time to make effect

I’m facing same problem. I’ve post a question with details on http://support.backendless.com/t/not-able-to-pass-email-setting

I’m facing same problem and I’ve posted a question with details on http://support.backendless.com/t/not-able-to-pass-email-setting

I did this and was still getting “password incorrect” error. However, I received an email from Google to let me know that an unknown app has attempted access to my email and was blocked. After I confirmed that it was me the problem was fixed.