Entity with ID not found

The code was working fine since a week ago! without changing anything, i noticed that push-notificaiton has an issue because no one received them anymore. After i debugging test we have found this issue. Which wasn’t an issue since a couple of days ago.

Error: Fault Code 1000 Entity with ID not found

App Id: D47C16E4-5548-E79C-FF19-9D440EFB4800

Hi Youssef

What SDK do you use? IOS/Android/JS ?
And could you please provide more information how we can reproduce your problem, maybe some code snippet how you send push notification

Thanks, Vlad

HI. yousef.
I’ve tried to send notification on my Android phone from your app, and all works fine.
Could you please provide more information:

  • where do you get this error,
  • what do you receive in response for registration device and sending notification,
  • have you tried to send notification on one device or group of devices.

Hi Oleg and Vald, thank you for your prompt response,

the error occur on Ios Devices,
device registration is fine, no error occur.
the problem happen when I try to send notification. Nothing happen, just an error with code 1000 Device Id not found, Please find attached a snap of the codehttp://support.backendless.com/public/attachments/8615a8bfa50d07afbaf0b8b8baffedac.png</img>

Hello youseff,

I’ve just checked push notifications with iOS devices and everything works fine. Make sure you have the correct certificate and password and that you’ve setup your project correctly.
Also I don’t see your publish method calling.

Regards, Olga

The thing is that at has always worked fine for 4 month… I have not changed any line of code…

Hello youssef,

maybe you registered the device with the expiration? in this case, it can be deleted when expire.
also from your screenshot it is not clear how you make push