Error 404 when debbuging. (4 steps down)

I would like to inform an issue during debbuging over UI Builder.

I have a platform with a 1) Login 2) Selection 3) Menu 4) Report schema.

When I want to review the page 4 schema give me 404 Error but if a go to step 3 the Preview is working without problem.

AppID: 147F3E51-266A-AAC4-FF2B-DFE9F84FD200

I’m dealing with the problem going one step up but would be great if I can launch the preview from the step 4 where I need to check.

Thanks, Mario

What is the name of the page for “Report schema” ?

  1. LoginPage
  2. MenuPropietarios
  3. MenuPropiedad
  4. AutorizacionesProp

Login: mark@mark.com Pass: mark

Here’s what i did:

  1. selected AutorizacionesProp page
  2. Clicked Preview in browser icon
  3. Login page opened up
  4. Logged in
  5. Got this:
    co… 2021-08-30 16-20-00

I didn’t see any 404 error. Please provide detailed step-by-step instructions to reproduce the problem.

Try again I was configure you account, sorry.
At that page you need to select the property because is step #3.
Then at step #4 is not working.

But if you start debugging pressing “Desktop Preview” using MenuPropiedad is working OK. It’s just 2 more click for debbuging but something wrong is happened.

Your Page #2

Your Page #3

Your Page #4

I am sorry, I do not quite understand “step3” and “step4”. Could you please show in pictures what I should click?

Step 2) “Seleccionar”

Step 3) “Autorizaciones”

I went through all these steps and still didn’t see any 404…

I can open a Zoom at time you can check it because is all the pages with the 4th in deep navigation with the same problem of debugging. Looks like something important. I found the way to continue the development but could be interesting to fix.
Mario

You are welcome to record a video demonstrating the problem and share it with us.

Backendless01.mov.zip (92.7 MB)

Ok, the issue of this Error is when I debbuging, I try to use Desktop Preview from the step #4 (VisitasProp) and give me 404 and if the same preview I start from step #3 (Menu Propiedad) it’s working until VisitasProp without problem.

Here’s the reason why you see 404:

The request is timing out. For me, it returns instantly. Does the same error happen when you login with my username and password (the ones you created for me)?

mark@mark.com pass: mark

Yes, time out at Step #4 but if I change the Desktop Preview to one step up #3 I can check the development. Why is happened ?

No if you enter as a user everything is fine. No problem is only using Desktop Preview when you received the TIME OUT.

I tried Desktop Preview, logged in with the credentials you sent me and everything worked just fine.

Yes but under development the Desktop Preview is not working.

Here’s a recording of what I see:

OK perfect do the same but choose the Step#4 could be VisitasProp or AutorizacionesProp. But if you start from Step #1 LoginPage or Step #3 MenuPropiedad no timeout for debugging.

You are almost there to reproduce the error!

Here’s a video where I start with AutorizacionesProp selected as the primary page in UI Builder: