"Error: Automatic publicPath is not supported in this browser"

about two days ago, I was getting the error “Uncaught Error: Automatic publicPath is not supported in this browser” in page previews, and page wouldn’t load. Simply re-loading the page generally solved the problem. But now the error just won’t go away and I’m unable to run our app… what is this error, and how does one get rid of it?

Hi @Alex_Klein, what browser do you use? Is the problem occurs only there or in all browsers?
Please provide us with your appId and container/page names so we could check it on our side. Thanks!


Hi Marina, I use Chrome (latest one). Very strange error, I was hoping you guys had seen it before… and it doesn’t happen on every page load, just ~50% of the time.

Would it be possible to provide a URL that demonstrates the problem?
Also, try turning off the browser plugins you might have.

Funnily enough, now the problem seems to be gone (hasn’t happened in about an hour) :roll_eyes:

Please let us know if it appears again, thanks!

It’s appearing again. Roughly 60% of the time that I load a “preview” of a page. I then just reload… doesn’t appear 40% of the time.

Is there any URL we can try?

Sure, https://worthypickle.backendless.app/api/files/ui-builder/containers/AlexK_prod/index.html?page=Experiments

Thanks. And what is your browser/version?

Chrome Version 112.0.5615.121 on a Mac

Thanks. I have the same, but can’t reproduce it (refreshed an app many times). But the issue definitely exists, so I’m gonna create an internal ticket and we’ll unearth what’s going on.

OK thanks for your efforts. If I get any more insight or data about when it happens (and when it doesn’t), I’ll let you know here :slight_smile:

1 Like

ChatGPT says " This error message typically occurs when you are using a version of webpack that doesn’t support automatic publicPath, and you are trying to use a feature that requires it.

Automatic publicPath is a feature that was introduced in webpack version 5, which automatically sets the publicPath option based on the output filename and the location of the HTML file. However, this feature is not supported in all browsers.

To fix this error, you can try to upgrade to a version of webpack that supports automatic publicPath, such as webpack 5 or later…

Maybe that helps? But it’s not clear why the issue happens only on every other page load

That’s right, I also saw this hypothesis when I searched the potential cause of this problem. I added (back then) this to the description of the ticket, but it’s really not very clear why this is a floating bug if this is really that problem. Moreover, we cannot reproduce it (for now, but I believe that we will find a way). Our engineer, who is the author of this part of the product, is currently on a short vacation, but in a week he will be back in the ranks and I am sure we will deal with this. Perhaps even earlier.
By the way, ChatGPT is something that we could integrate not only in Backendless, but also on support :slight_smile:

1 Like

Hi guys, I noticed that when working on one of our containers, this bug seems to be reproduced 100% of the time for me (on Chrome Version 112.0.5615.137). Perhaps it will be reproducible for you too? Try loading this simple page:


I have disabled various extensions on my Chrome browser but still get the error. But when I load the page in an anonymous browser (same Chrome), I do not get the error. It’s very annoying, I can’t really work on Chrome now :frowning:

Hi Alex,

thank you for the information.
Unfortunately, this is what I see on Chrome version 113.0.5672.63 (using macOS Monterey 12.5.1):

But as a said earlier, we’ll find out what’s the issue. Our engineer will contact you soon.


1 Like

@Alex_Klein It’s strange that you don’t get an error when loading the page in an anonymous mode.
Have you tried to disable all browser extensions?
Could you please show the screenshot of the error (in console logs) when you receive it?


Yes, very strange — and the error doesn’t appear with ALL extensions disabled. I have now figured out which extension is causing the error (this one by Zoho). So I think the issue is resolved for me for now.

What’s very strange though is that the error appears 100% of the time for preview pages of one of our containers, and hardly ever for preview pages of a different container (!?).

Here is a screenshot of the error:

Thank you for the info, @Alex_Klein. Glad you have found out the reason. Seems this extension injects code which breaks our code. We’ll investigate it, but I can’t guarantee that we will find an appropriate solution since we can’t modify this plugin’s code. But we will take a look into it anyway.