Support Topics Documentation Slack YouTube Blog

Error in whereClause with objectId form Users table

Hi!

When you add a condition for objectId = ‘XXXXX’ to a whereClause of the Users table it doesn’t select anything.

It is a very strange problem that has made me lose several hours. The problem occurs in a more complex whereClause, but to simplify it here I put a very basic whereClause:

Here you have attached a minimal example Application with the error:

The App ID for this example is EE93A317-9965-49A1-FF06-BEB3F3B8F000
I’m testing the App in IOS simulator and IOS device and I have the same error.
I’m using backendless_sdk: ^1.1.4 version

Hi @Dani_Sevilla.
Now we will check this problem and answer your question, please wait

Hi @Dani_Sevilla

I run your project and got the following results:
image
It seems to work fine.

Try to clean and rebuild your project by running the following commands:

flutter clean
cd ios
pod update

Best Regards,
Maksym

Hi @Maksym_Khobotin

Yes!! The problem was the pod update:

Now is working ok!

Thanks a lot!!!

I’m glad you succeeded, good luck!