Error performing deploy

i’m really liked Backendless platform.

But i’m facing a strange error, which i cannot find a solution for an “[ERROR] Input/output error” error while performing an Deploy to Server Code.

It worked before, but for no reason stopped working, and there is no log that i can figure out what’s is happening :frowning:

The full log is attached on this post.

Best regards,
Wakim Jraige.

backendless_log.txt (12.33kB)

We’re having exactly same issue. I tried to update Coderunner and publish timer code with Win10 and Mac. Both gave the same I/O Error. This started yesterday (15th June). Also I noticed that our custom timer stopped running yesterday and running it manually doesn’t really execute the code (we have an e-mail confirmation sent when the timer runs).

Hope you’ll find fix soon!
Larri J

I think it’s a problem related with my application, because i have uploaded all my business logic code (just one custom event handler) to another application and worked.

I was getting an timeout for no reason when calling my custom event handler. Which i cannot debug without logs.

But with migration to another app, all problems are resolved.

In our case we need to get the deploy done for our existing app which gives input/output error…

Hello everyone!

Wakim, I see in you log file that in spite of the exception, deploying has been finished correctly. Can you confirm it?

Larri, please try to re-deploy your custom code and check timer execution again. If it doesn’t help - please open a separate problem for this issue. Provide there your app-id so we can check your app.

We are working under the problem with IO exception. We apologise for these problems.
Thank you!

Thanks Alexandr,

I have to migrate all my stuffs to a new app (because my app is in development yet), which is working everything.

On my old app, i still can’t publish the server code, same IO Error from yesterday. I deleted the Custom Event Handler which i was trying to deploy, but he doesn’t appear again using (but i don’t know if it appear automatically without creating it in console first).

I discovered this issue because i was getting strange timeout’s in my Custom Event Handler, so i deployed an version with new logs. I’ve purchased the 20 seconds extension, but didn’t work either :confused:

I think it’s something related with my old app, which app-id is 0331A267-8882-04C2-FFFA-A41ACF56F000.

Thanks for support Alexandr :smiley:

Wakim, we’ve made some changes in your app with id 331A267-8882-04C2-FFFA-A41ACF56F000. Can you check it?

It worked Alexandr, thanks :smiley:

But i’ll continue using the new app instead of the old, because i’ve already migrated all my clients to use it.

Thanks for resolving this issue.