Error while saving file

Application ID: 3757D039-71F0-2B1C-FF79-95D5F0B8D000
Error UID: 476A290B-A97E-4CF4-FFB9-A7F8C19C3300

Backendless encountered an error while handling the request. An internal trouble ticket with ID 476A290B-A97E-4CF4-FFB9-A7F8C19C3300 has been created and we will be investigating the issue.
/opt/backendless/repo/3757d039-71f0-2b1c-ff79-95d5f0b8d000/files/ does not exist
java.lang.IllegalArgumentException: /opt/backendless/repo/3757d039-71f0-2b1c-ff79-95d5f0b8d000/files/ does not exist
	at controllers.console.FileManagement.lambda$fileEdit$17(
	at com.backendless.async.BackendlessExecutorService.lambda$submit$0(
	at java.base/java.util.concurrent.CompletableFuture$
	at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(
	at java.base/java.util.concurrent.ThreadPoolExecutor$
	at java.base/

Problem description

I have some raw text files in my files folders. Sometimes I’m trying to edit file content and save the updated file, but got an error - unable to save the file.

Steps to reproduce

  1. Go to Files and open existing file.
  2. Edit file content and tap “Save” or “Save and Exit”

Hello @Eduard_Mukhametgareev!

Thank you for your question!
Please describe the steps so that I can reproduce the problem and I will try to help you solve it.


Hey @Alexander_Pavelko! Sorry, I forgot to edit post template. I have updated it, can you take a look, please?

Hi @Eduard_Mukhametgareev

Please check if the file you are trying to edit exists.

Yep it definitely exists - otherwise I won’t be able to view or edit it.
Somehow I tried again - and it worked now. Is it possible to investigate the issue? It is not the first time when I’m unable to save updated file.


Hello @Eduard_Mukhametgareev

We are investigating your problem. In which cluster is your application located EU or US?


Thanks for investigating! Application is located in EU.

Best regards,