EU App Creation

Hi, there seems to be a problem creating EU apps. They create but are unable to open them in the console. US apps seem to work fine.

Hi Kev,

I was able to access both of your apps just fine:

Could you try navigating to the console in EU by using its direct URL?:

Please let me know if it worked.


Hi, that is the URL it navigates to for me but then shows the backendless login page and if I enter credentials it says the server encountered an error.

Do you log in to Backendless Console with your hotmail account?

I do yes. The US app I created when I couldn’t get the two EU apps to open works fine, although I have deleted that now as I just wanted to test it wasn’t all apps.

Do you have any browser plugins or anti-viruses that may impact the user experience?

What browser do you use to login? Have you tried it with another browser?

Using Chrome and just tried with edge with the same error. It doesn’t even look to login, just shows the error straight away. No plugins but have antivirus.

Could you click the Report problem link and paste the error details in this thread?

Application ID: null
Error UID: A0C0CB15-2294-821B-FF61-21472E86E500

Backendless encountered an error while handling the request. An internal trouble ticket with ID bl-server:A0C0CB15-2294-821B-FF61-21472E86E500 has been created and we will be investigating the issue.
Cannot invoke "String.startsWith(String)" because "hashedPassword" is null
java.lang.NullPointerException: Cannot invoke "String.startsWith(String)" because "hashedPassword" is null
	at com.backendless.common.helper.BCryptPasswordHelper.checkPassword(
	at com.backendless.developer.DeveloperLoginService.checkCredentials(
	at com.backendless.developer.DeveloperLoginService.login(
	at controllers.console.DeveloperLogin.lambda$login$0(
	at com.backendless.async.BackendlessExecutorService.lambda$submit$0(
	at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(
	at java.base/java.util.concurrent.ThreadPoolExecutor$
	at java.base/

Thank you, this is very helpful. Could you please confirm that you can login to the US cluster?

I have deleted that app but it just went straight the app when I clicked it as I’m already logged in. Not sure why the US asks to login again. I’ll create another US app now to test

Yes just created this and it just goes straight to console:

If you do not mind, please use the US cluster for now while we figure out what happened. It looks like your account was not correctly synchronized between the US and the EU clusters.

I will do. I’m new to Backendless so just doing a few test apps to see if it will suit my requirements. I know I shouldn’t really ask another question in the same thread but are you able to set a limit on the scale app for development so any costs don’t spiral out of control?

I appreciate your flexibility.

The answer to your question is yes, you can. When your app is on the Scale plan, you can set the max tier threshold in the Backendless Console. Here’s what it looks like:

Excellent, thank you for that!