Exception during user register ??

Hi -
My user register was working fine - and then I added beforeRegister() and afterRegister() hooks to it.
While my beforeRegister() is running fine till end - however still I get below exception in afterRegister() - so something is happening in between - not able to figure out though.
Can you please help ?
I have already done ‘mapTableToClass’ for all tables - in my Bootstrap.java.
2016-05-24 19:16:46,254 | com.mytest.events.GenericUserEventHandler | ERROR | In afterRegister, received exception: Code: 0 Class: class java.lang.RuntimeException Message: java.lang.RuntimeException: java.lang.RuntimeException: java.lang.RuntimeException: java.lang.RuntimeException: com.mysql.jdbc.exceptions.jdbc4.MySQLSyntaxErrorException: Table ‘09667F8B-98A7-E6B9-FFEB-B2B6EE831A00.37E123B0-66AB-935F-F.36524280-898B-A3B2-F.E0F43’ doesn’t exist in engine

Hi, Aditya!

Do you still get this error? Because the table ‘09667F8B-98A7-E6B9-FFEB-B2B6EE831A00.37E123B0-66AB-935F-F.36524280-898B-A3B2-F.E0F43’ is present in database.
If you still encounter the error, please send us your project at support@backendless.com so we can reproduce it.

Hi -

I tried today and its still same issue.

Have sent the mail containing the project.

Please do let me know if anything else is required.


Let me know if you are not able to reproduce the issue. Thanks.

I have reproduced your issue, we are working on it

We have fixed this issue, please try again

Hi - That problem is solved (user is getting registered) - but it seems to be creating new issue - I am now getting below exception.

This does not seem to be issue with my code - as I get this exception - even if I have totally empty afterRegister() function.

public void afterRegister( RunnerContext context, HashMap userValue, ExecutionResult<HashMap> result ) throws Exception {

To reproduce it - just delete all code from afterRegister() and run the app - you should get below exception.

SEVERE: Unable to adapt array to data type: class com.mytest.database.CustomerCa
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at com.backendless.coderunner.runtime.task.EventInvocationTask.runImpl(E
at com.backendless.coderunner.runtime.concurrent.ExtendedRunnable.run(Ex
at java.lang.Thread.run(Unknown Source)
Caused by: java.lang.RuntimeException: Unable to adapt array to data type: class
at weborb.reader.ArrayType.adaptToClass(ArrayType.java:335)
at weborb.reader.ArrayType.adapt(ArrayType.java:229)
at weborb.reader.AnonymousObject.getPropertyValue(AnonymousObject.java:5
at weborb.reader.AnonymousObject.setFieldsAsBean(AnonymousObject.java:34
at weborb.reader.AnonymousObject.adaptToClass(AnonymousObject.java:289)
at weborb.reader.AnonymousObject.adapt(AnonymousObject.java:140)
at weborb.reader.NamedObject.defaultAdapt(NamedObject.java:86)
at weborb.reader.CacheableAdaptingTypeWrapper.defaultAdapt(CacheableAdap
at weborb.reader.AnonymousObject.defaultAdapt(AnonymousObject.java:117)
at weborb.reader.AnonymousObject.defaultAdapt(AnonymousObject.java:95)
at weborb.reader.CacheableAdaptingTypeWrapper.defaultAdapt(CacheableAdap
at weborb.reader.ArrayType.defaultAdapt(ArrayType.java:135)
at weborb.reader.ArrayType.defaultAdapt(ArrayType.java:65)
at weborb.util.io.Serializer.fromBytes(Serializer.java:178)
… 7 more