Support Topics Documentation Slack YouTube Blog

Exporting users from the data browser page does not work

Hi,

I found that exporting user data from the “Data browser” page doesn’t seem to do anything.
Project URL I try to use: https://develop.backendless.com/FaceGenius/data/tables/Users

It properly shows the message ‘in queue’, but nothing happens here at all.

At the same time, the export function in the Manage -> Export page works pretty much immediately. Unfortunately, I cannot use it since it exports the full table. I need the sorted and filtered data exported so I can share it with our team. I was able to filter and sort the columns through the ‘Columns’ dropdown on the URL above, but the export simply does nothing.

Do you have any idea what can be causing this, and how can I export the data I need?

Thanks,
Justinas

Hello @Justinas_Grazulis

Can you provide your Application ID?

Hi @Inna_Shkolnaya,

It happens on F2FE78BB-5D08-44FE-B074-6E7C29B49B03 (dev project) as well as 92E6BE6B-8DE1-D74E-FFC3-F1B602528600 (our live project).

Thanks,
Justinas

Thank you.
I’ll investigate this issue and answer you as soon as possible.

Regards,
Inna

@Justinas_Grazulis

I just added a filter to the column and exported the table. Export was successful. You can see the result in the “Export” folder.
If this is not what you had in mind, then please describe in more detail the filters that you used before exporting the “Users” table.

Regards

Hi @Inna_Shkolnaya,

Thanks for a quick turnaround. I can see the export functionality is working, and I missed the exported file because I was looking for a folder named with today’s date. Mistake on my part!

Now that I see the exported data, I understand this export functionality still exports ALL the fields (no matter if I re-order or disable visibility for some columns). A follow-up question: is it possible to export partial data (or the data that I choose to see on the “Data browser” tab?

Thank you!
Justinas

Unfortunately, when exporting the backendless will export all columns. And the columns whose visibility you turned off in the data browser will be filled with “null” value.

Regards,
Inna

Got it, thanks for the information :slight_smile: