"Eye" visibility toggle of components in UI builder not working on user interface load


In UI builder, in the right pane, the second tab looks like a burger menu, and it displays a tree of all components in a page.

To the left of each component is an eye. I had understood that this eye allows for toggling the display of some elements (in UI Builder only, not in the end result, so I am not talking about the “Display” checkbox in the first tab with the paint brush).

Indeed the eye icon works as such when clicking on it within a displayed page. However, when first rendering the user interface in UI builder, this setting does not seem to be taken into account.

Example :
I have a loader overlay which blurs the page and have toggled its display off : the eye is greyed out and barred (see screenshot). When first loading the user interface, the loader overlay is displayed nonetheless, and I believe this should not be the case. When I go into the component tree, I click once to enable the display, and once again to disable it, and now the behaviour is correct : the layer is hidden.


This can be viewed on pages L1-view-my-logbook and E8-add-new-equipment-reminders of my app D7075715-5086-625A-FFAB-39C2F40FB200.

Best regards.

Could you please record a loom video illustrating the problem?

Here is a video illustrating this:

First I show that there is a component called “LoaderOverlay” that blurs the background. When switching over to the Logic tab, if the component is visible, it shows when returning to the User Interface tab: this is the expected behaviour.

But then, starting at 0:15, I show that even when hiding it, if I go to another tab (or to another page, for that matter), then when returning to the User Interface tab, the component is displayed, although the eye says it should be hidden.

Thanks for the video.
I’ve created the inner task in order to investigate the problem.
We will post here about any progress.

1 Like

Hello @Nicolas_REMY

We’ve just updated cloud servers with a fix for the issue you described above. Could you kindly let us know whether fix works for you well?



Indeed it looks like it is fixed. Much more practical, thanks !


1 Like