Failed to add column

This is in fact two problems Im facing…

  1. When I through the admin interface try to add a column to a table, it fails every time, regardless of naming of the column and choice of datatype / defaults.
  2. When I through the Flex SDK try to add a row that has properties not already in the table (and thus should trigger the addition of the column automatically, it fails with a MySQL exception that the Row is too big and that I should change it to TEXT or BLOB.

Every time I add a total of five columns, it stops allowing more columns, and from that moment on the table is “locked” in the ceiling of columns and will not allow any more new columns, even if I remove one of the existing ones. The only solution is to recreate the table, however since it happens every time I reach 5 columns, there is not much I can do with it.

I am also getting locked up when adding more than a few columns either programatically or through the schema editor online.

The problem still remains

I just ran into the same problem today. I can not add a new column on one of my app’s tables. Adding a relationship works, though.
It does not matter what Type I select, it always fails (with Server Error 400 in the HTTP-Log).

When trying to create the field via the api (just submitting data with any new field) I get Server Error 500.

Any Ideas?

Could you try creating a new table and see if the problem occurs there?

I just did (get out of my mind, please ;-)) and no problem in the new one.
The thing is, this my user-“proxy” table, which holds information I can’t save into the user (yet), because it needs to be editable by admin-users.
So if I need to stick with this table, it means logging in as every user and changing the object-id pointer field.


If you originally created that table more than 2 weeks ago, it will exhibit that problem. Is it possible for you to delete the table and re-create it again?

Uhm I actually created this whole app at June 26th, this very table is a bit younger (29.06.2013) - would that fit your timeframe for the problem?
I think I did create a new field just a few days ago, so it worked flawlessly until then.

I will now go ahead and recreate the data, or do you happen to see any other way?

Yes, please recreate the data and let us know if the problem went away.


Okay, so this was really fixed by creating a new table with all the same fields and re-creating all the data. But now I have the exact same problem on another table with way more fields and way more data, plus about 10k related records.

(What I’m trying to say is, I can’t by any chance re-create this table.)

So, do you have any idea what may cause this?
Here’s all the info I got:

{"message":" Failed to add column ","code":1}

I even tried renaming a field I could spare - no change, I always get an error:

{"message":" Update column failed ","code":4}

Could you please look into this? Thanks a lot! Our app id is 3EC9156B-FDDA-1998-FF35-4DA70D8C2800 and the Table I’m trying to edit is “Setcard__c”.

Thanks in advance!

Hope this helps: Now that I tried renaming a field (“Contact_Person__c”) I get an Server Error 500 every time I try to save a Setcard__c with that field set. (No matter if it’s done via the API or via the Backend)
Seems to me as if I could rename it “halfway through” - is that possible?

I’d like to double-check with another field, but I don’t have any to spare, sorry.

Update: In fact, it seems I cannot fill any field that has not previously held any data anymore. They do exist in both the Backend and the API, but I cannot write any data, because else the call will fail with Server Error 500. Again, no matter if Backend or API.
I’m afraid I can’t add anything to this model right now and I can’t recycle old fields, so I’m pretty screwed, right?
Any Ideas, please?

Best Regards,

Just to get the closure on the thread - we manually fixed the table you mentioned and it should be working now.

Yes, thanks to your awesome support this was resolved in a matter of hours.
Thanks for that!

Keep on your excellent work!


Hi Peter,

This problem should be resolved in the latest update we did this week. Could you please try again and let us know what you find?


UPDATE: June 23rd: The problem has been resolved in the update we performed on our site.