Failed to Import Bridging Header

I opened two projects today that have worked for months. Both of the projects reported the same error. with different missing files. I’ve listed a number of settings below.

Project 1: error: 'Backendless.h file not found #import "Backendless.h"
Project 1: error: failed to import bridging header

Project 2: error: 'Backendless.h file not found #import "CustomService.h"
Project 1: error: failed to import bridging header
  1. My Bridging Header file includes the following for both projects.
#import "Backendless.h"
  1. I am using CocoaPods for the SDK install. My podfile is shown below.
platform :ios, '8.0'

target "Instagram" do
    pod 'Backendless'
  1. I am running Backendless 3.0.44.

  2. The image below shows the setting for the bridging header under Build Settings.

Any help sorting this out would be appreciated.</img>

Hi Jon,

Does it work on a fresh new project?

Also can you send us at least one of your projects so that we could look into the problem?

I’ve attached a tutorial project I am working on. I have not tried it on a fresh project. (20.3MB)

I opened your project and hit “Build”. Here’s the error I am getting. It looks it does not even get to the Backendless part since the bridging header you’re referencing cannot be found.</img>

The project uses version 3.0.43 of the library. The latest release is 3.0.44:

To fix the error, you can comment out lines #89 and #144 in Backendless.h located at:



Thanks for the reply. I find it odd that the project it using 3.0.43. I updated the pod and it mentions it’s running 3.0.44. The screen shot is below.

This is strange. The latest code in github has the files which XCode complains about:

Also, I followed the instructions from this guide to create a new project/workspace and everything is compiles without a problem:

Thanks Mark. I appreciate the help.