FAULT = '1011' User has no permission to create entity

I’ve been getting this error

FAULT = ‘1011’ [User has no permission to create entity] <User has no permission to create entity> a lot over the last few days where I was previously successfully creating entities in the DB. Nothing has changed with my permissions setup. Today I have enabled an additional permission but it hasn’t helped.

Has a deployment been done recently that has caused this?

I’m updating CocoaPods now and I see there’s a new version. If that fixes the problem I’m significantly concerned that when I get to a production release there will be times when my users are unable to do anything because a server deployment has broken everything and I need to release a client update to fix it. I’ve mentioned these breaking changes before when I’ve had issues and had to update the client SDK to get things working again…

Updating the SDK hasn’t helped this time so I don’t know why I can no longer create anything using my custom business logic.

If I login with the REST console I get exactly the same result. Also the same using the Android SDK. So at the moment I can create new users and login users using the iOS SDK but none of my calls to my custom business logic seem to work. The deployed custom business logic and the permissions haven’t changed in at least 2 weeks. I think the issues started 4 days ago (14th June).

“code”: 1011,
“message”: “User has no permission to create entity”

Please provide your application id and data table name (where you try to add new records). We will investigate this issue.


The custom business logic is trying to operate on the Business and Membership tables primarily, though a single function operates on multiple tables - I haven’t checked which one fails. The function queries Membership and then saves Business as the first things it does.


Still seeing the same server response. From the website it doesn’t look like there’s been a new code runner release so I’m not sure what i can try to investigate this issue.

Any news on this, or a recommendation on what I might be able to do about it?

Hi Wain,

Please let me know the name of the service/method that exhibits the behavior you described?


This is my Management custom business logic service, the method POST /createBusiness

Hi, Wain!

Can you provide the valid request body for this request(POST /createBusiness)?
I get this response with default request body:
“code”: 0,
“message”: “Type:“java.lang.IllegalArgumentException”, Description:“Identity cannot be null”, ExceptionClass:“ServiceException” {Msg:“none”, Cause:“none”}”

Can you also provide us the exact part of your business logic method that causes the “User has no permission to create entity” error?

I don’t know the exact part, I haven’t run it through the debugger. The important point for me is that it used to work and it hasn’t changed since it worked so whatever broke it is behind the scenes.

I don’t have access to anything to create a sample request at the moment, but the error you see is because you need to be a logged in user to make the request. It isn’t an ideal error response…
I can create a sample request tonight.

Hi, Wain!

In the previous release we fixed some permissions issues. So you need to update the permissions you’ve set for your app to work properly. In particular, in your the createBusiness request 2 roles are present at the same time - AuthenticatedUser and ServerCodeUser. If at least one role has DENY permission - the overall permission will be DENY. Since you had DENY permission for AuthenticatedUser, the operation was declined. For details contact Backendless Permissions Documentation
I’ve changed AuthenticatedUser permissions to GRANT for tables: Business, Membership, Rota, Shift, Swap and Team for your request to succeed.