Flutter API set up

Hi I downloaded zipfile for flutter APi setting.

and only change I made was on the client set up side is this ,Copying the sub domain name
void initState() {

I got this error

3 positional argument(s) expected, but 1 found.
Try adding the missing arguments.dartnot_enough_positional_arguments

I still ran it bu did not get the Hello World output.

I am new to dart and flutter but making good progress with your instructional videos an and flutter’s


I tried to reproduce you issue, but in my case this works without any problems.
Can you please clarify the version of our Flutter-SDK you are using?

Best Regards, Nikita.

Hi Nikita

Some how it worked after I removed the domain name.

Thank you I am back on track.

@GANESH_KRISHNA, if I understood you correctly, initApp with custom domain does not work for you?
Can you describe this problem in more detail?
Which version of Flutter_SDK are you using?

Best Regards, Nikita.

Hi Nikita

Flutter 2.5

I have added snap shots on the template I downlaladed wiht the problem when I copy the auto generated sub domain BEndless.to initapp.

Thank You.


pubsmec yaml.png

subdmain copied  problem occurs..png

No problem.png

6.0.1 is a very old version of backendless-sdk. This version does not support custom domains.
The latest released version is 7.1.5. You need update your pubspec.yaml file, just replace:
backendless_sdk: ^6.0.1
backendless_sdk: ^7.1.5.

You can follow new updates here: backendless_sdk | Flutter Package.

Best regards, Nikita.

Hi Nikita

Did as advised velows Stil no luck.

Same problem exist.



initWebApp is not available in the current version, now initialisation takes place in 1 initApp method:
Backendless.initApp(customDomain: 'https://YOUR_URL' );
Backendless.initApp(applicationId: APP_ID, androidApiKey: ANDROID_KEY, iosApiKey: IOS_KEY);

I recommended reading our documentation. How to properly configure the application was described by the link that i wrote earlier.

Best Regards, Nikita.