Forgot Password - Email Not Received


I am trying to retrieve password for my backendless account using the ‘forgot password’ option. However, I am not receiving any email from backendless. Please help.
App Id : 55F928E7-9D6E-937F-FF72-80924AE09B00

Pranav Patel

Hi. What is your email?
Does it the same as your email for the support account (here)?
I checked the list of applications bound with that email and found nothing.

I have tried for two


1 is my primary email associated with the application ownership. I get billing details and other notifications here. 2 is for development team.

Email associated with the support account here is a normal gmail account.

Also, I have tried to send test email via messaging->emails from backendless console. I receive email at my gmail accounts but the same doesn’t happen for professional mails. i.e.

I found the app, where is the owner.
And checked that our smtp woks fine.

Could it be that a smtp/imap/pop3 provider for has a blocklist or limitations?

We are also checking our smtp configuration for specific task – “forgot password” emails.
Will post here about the result.

1 Like

But if that was the case, I should not be receiving emails from billing@backendless too, right? I got one yesterday. Meanwhile I haven’t received emails from for quite sometime now. Even email notifications of files export are not coming in.

We found a problem with the CIS on the server side.
It possibly has a very strict security policy.
Here is the response from to our smtp:

Connection refused. has a poor reputation on Cloudmark Sender Intelligence (CSI).

Our team are working on it. They are investigating whether we can do something to remove our address fro that list.

Its working now. Thanks Oleg!

Same issue coming for
Please provide solution.

Pranav Patel

Hi @Pranav_Patel

out engineer will take a look as possible and provide you with an update


Dear Pranav Patel,

The first time you reported the issue, I submitted a support request to Cloudmark to unblock (which is the mail server where your emails are sent through our server). When I saw that the problem recurred, I decided to thoroughly investigate the issue to resolve it in the best possible way, ensuring no one else experiences discomfort. I checked all publicly known blacklists, and our mail server’s IP address is not listed. Furthermore, I sent emails through our server to a dedicated resource (, and our emails received a score of 9.2 out of 10, which is excellent.

Next, I searched forums for similar complaints and found this (, where people were complaining about Cloudmark. It seems that the issue lies in Cloudmark creating its own blacklists through an unclear procedure. The maximum we can do is submit a request to them for unblocking, specifying the exact block message, but we can only do this once a day. Unfortunately, we cannot expedite the process or directly influence Cloudmark. There is also no guarantee that they will consistently respond to our unblocking requests, and at times, they might simply ignore us.

Therefore, if you provide the exact error message here, we will submit a request to Cloudmark for unblocking. If there is anything else we can do from our end, please let us know.