Get the object with nil features

My ios app was working well until a few hours ago but now I got a problem
The return from the server is a little bit strange.
(But my android app and REST test was fine) - this is why I cannot guess the reason.

Can u please guess any reason?
The code is like below:

func downloadFrontData(_ completionBlock: @escaping (_ data: [FrontData]?, _ errorMessage: NSString?) -> Void) {
 dataStore?.find({ (collection) in
 completionBlock(collection?.data as? [FrontData], nil)
 }, error: { (Fault) in
 completionBlock(nil, Fault?.description as NSString?)

▿ <pet_place.FrontData: 0x60000030dad0> #0

  • super: NSObject
  • objectId: nil
  • events: nil
  • recommItems: nil

my application ID: 6E11C098-5961-1872-FF85-2B0BD0AA0600

Hi KenChoi

Our iOS developer is already investigating this issue. We’ll contact you as soon as we get any results.

Regards Anton

Thanks for your reply, but I need to know what this issue has happened.

Please let me know after this issue has been resolved.

We’ve used your code and targeted it at your app and did not manage to reproduce the behavior you’ve described. Can you repeat the request and verify that problem still occurs? If yes - please send your project to, we’ll dig into it.

Regards Anton

Hello, I sent email and please check.

I think the version of my Xcode could be issue - Xcode9 Beta 4
But still cannot understand bcs it was working well even yesterday.

So please check my email and let me know.



Xcode 9 support will be available after its release. For now I highly recommend you to use the stable version of Xcode 8 (your project works fine in Xcode 8, I’ve checked) until Xcode 9 is released out of beta.


Ok, understood. But I cannot understand why this sudden error got happened. If possible, please notify your team to fix this error. Always thanks for your support ^^

Hello, I found sth strange in the progress of migration from 3.x to 4.x.

I tried the sample of version 4.x, sth like <myproject>-CRUD. The sample project is working well but my project is still not working even I finished the implementation of API Changes. I know u guys are busy but can u check with your iOS Dev team?

I will email my sample project and CRUD sample from Backendless console.

Please check

Hi Ken,

Looks like you need to figure out what exactly fails to work in your own project. Reviewing your project is not a part of a free support.
In case you find that some of the API methods is failing, please create a dedicated topic with a detailed description of a problem.