Getting Network Error from GET request

On Data Sponge mission 4, I’m getting,

“message”: “Network Error”

in the response body when I click, “GET.”

I just tried it in your app and it works for me. Here’s a screen recording:

Interesting, I got it to work by switching the “USE” dropdown to “REST API Key”

What did you have selected before (when it didn’t work)?

I had what you had in the video,

Must be something with your network provider…possibly blocking our subdomain. Glad it worked though.

Yes, the error is also popping up anytime I try to invoke any business logic through the server. Are you aware of any solutions to avoid getting blocked by the network provider?

Unfortunately, I am not aware of any solutions since it is entirely outside of our control. Try reaching out to the network provider to see why they are blocking the requests.

Hey Mark, just wanted to reach back out and let you know how I solved the network issue in case anyone else comes to you with the same problem.

I ended up trying a bunch of different solutions that are typical for SSL errors, none of which worked. I finally found a solution from a reddit post which recommended changing DNS settings from auto to: Preferred: (
Alternate: (

The full path to get to this is: Settings → Network & Internet → Change Adapter Settings → Properties → IPv4 → Properties → “Use the following DNS server addresses”

I hope this helps anyone else who has to deal with this issue as it was bugging me for quite a while.

Daniel Shapiro

1 Like

thank you very useful!