"Go to page" error on Safari desktop browser

Hello,

I’m getting an error when using the App Router “Go to page”. This is the error:

[Error] TypeError: Spread syntax requires ...iterable[Symbol.iterator] to be a function — sdk.js:14:880995
	Ni (sdk.js:14:2296050)
	(anonymous function) (sdk.js:14:2298151)
	Eg (sdk.js:14:2262261)
	Yi (sdk.js:14:2299854)
	dk (sdk.js:14:2316448)
	dk
	(anonymous function) (sdk.js:14:2362794)
	Uj (sdk.js:14:2313094)
	Lj (sdk.js:14:2309191)
	Lj
	(anonymous function) (sdk.js:14:2258769)
	(anonymous function) (sdk.js:14:2362794)
	jg (sdk.js:14:2258715)
	ig (sdk.js:14:2258650)
	fk (sdk.js:14:2318188)
	(anonymous function) (sdk.js:14:2362794)
	(anonymous function) (sdk.js:14:2317376)
	V (sdk.js:14:2361827)
	(anonymous function) (sdk.js:14:2360516)
[Error] TypeError: Spread syntax requires ...iterable[Symbol.iterator] to be a function
	(anonymous function) (sdk.js:14:2360595)

I’ve tested on chrome web & mobile and safari web & mobile and the issue only seems to happen on Safari desktop.

As I was writing this I tried to debug the issue further and noticed I’m also getting similar errors in another area, again this is only happening on Safari desktop so it’s hard for me to tell if it’s an error on my end or Backendless.

Visit: Preview

  • Click the “ticket button”
  • With the console open, click the ‘+’ icon twice, and the errors will appear.
  • Also click the “checkout” button and the “Test button”

APP ID: BFAAA9DA-A670-4AA6-B225-2B43342141F0

I’ve created the inner task for investigation.
[BKNDLSS-29708]
The result will be posted here.

1 Like

Update:

This isn’t just happening on “go to page” it’s happening with many other scenarios as well. I simply tried to type or paste into a field and then the screen goes blank and produces that error.

Making safari pretty much unusable for my app

Does it work in other browsers? Do you have a test page demonstrating the issue?

Yeah, it works in other browsers: Safari mobile, chrome & chrome mobile. Haven’t tested any others.

Just this page - https://link.nctrl.app/dcirWx

Hello @Hezzron_Austin

Thank you for the additional information. We will investigate the problem and report back to you as soon as possible.

Regards,
Inna