Google Apps SMTP settings not authenticating

I’m trying to enter the following information into the email settings in backendless:

SMTP Server:
Port: 25
From: Fittingly
User ID:
Password: password to the account

It either says it can’t reach the server on that port or the username and password is incorrect.

Any ideas?

Perhaps this will help:

Hey Mark,

Want to provide this solution for people with Google Apps accounts. Google places restrictions for newly created account off the bat. In order to get this working you need to follow these steps:

  1. Login to your admin account by going to
  2. Click on “Apps” from the list of icons
  3. Click on “Google Apps”
  4. Click on “Gmail”
  5. Go to “Advance Settings” all the way on the bottom of the list
  6. Scroll down to “End User Access”
  7. Check the box that says “Allow users to send mail through an external SMTP server when configuring a “from” address hosted outside your email domains.”

It can take up to an hour to propagate, but worked for me after waiting 5 minutes. Hope this helps people moving forward!