Google Login - "OAuth2 provider is not found"

I am getting the error: “OAuth2 provider is not found” from Backendless when I try to login with Google after getting the info from Google after logging in with them. I assumed it’s maybe because I need to hook up the Client ID and Secret, after checking the docs. However, I don’t even see “Social Options” in the Manage > App Settings area.

Anything I may be missing here, which could be causing this error? Thanks in advance,

Hi @vincent-guerin!

“Social Options” section was moved to “Users” > “Login Providers”. For enabling Google login or any other social login you must configure it in your app first.

Regards, Andriy

Thank you for the quick response. I added those in there, but I’m still getting the same error. I’m using the Web Client option in the Google portal, and I also copied in the clientID to the URL types/schemes in my plist. Any thoughts on what I could be doing wrong?

Actually never mind on that, I reverted my plist change (is that actually needed?), and it seems to be working now!

More info, looks like that plist entry is indeed needed for the Google side of things. I think things are working fine now. I’ll do more testing and let you know if otherwise. Thank you again for your quick assistance!

Such problem can be caused by API key mismatch when key from redirect URL and key that is actually used by client are different. By default in “Login Providers” section REST API key is used. Unfortunatelly it is not obvious but we will fix it in next release.

Regards, Andriy

Thanks, and no worries. I believe this is now solved with the info above, so thank you again for your great support!