Help with API call that isn't working


I have written a cURL API call where there is 1 header and 3 parameters in the URL itself.

I get this error when I try to invoke this call:

I have run the call in postman and it works there, so I must have made a mistake with the way I have built the call in Backendless but I cannot figure out what the issue is:

Hi Luc,

What is your application ID?


Hi Mark,

The ID is 8518B92E-A6AA-5589-FFA0-B863E4A63F00

Thank you

For me request blocked by CORS.

Also I see 5 hidden headers, could you show it? Or provide full request from Postman if it possible.

And last but not least, I found problems only with external API, and would be important to say, here we provide help with our service.

Hi Dima,

These are the 5 hidden headers:

Thank you for your help!

Unfortunately, but nothing important here :frowning:

For now, I could offer you to make this request with codeless in ui-builder and compare it with one from postman(in browser dev tools).

Thank you Dima, I ran the API call in UI Builder and it’s worked. It looks like there is an access block when invoking in the cloud code area. I’ll make sure to test all calls in UI Builder from now on.

I just tried replicating it in UI Builder and I noticed that adding https:// in the first text block is not needed:

Try removing it and see if it makes a difference.


Thank you Mark, I user https in other calls and they work ok, am I better to leave out every time from now on?

I think so. When I had https:// in there, the resulting URL (you can see it when making the call from UI Builder) looks like this, which I believe explains the ECONREFUSED error:

1 Like