How to suppress "NaN"

Hi, This problem is not a show stopper, but just a tidyup. Besides teh points below, Marks tutorial worked brilliantly.

When I completed the tutorial and preview the page, before editing any of the input boxes, the display is as follows…

How can I avoid the NaN being displayed.

When I try to suppress the NaN by defaulting X and Y to 0, I get NaN again, but when I enter + in the operator, I get…(should only be one “0” being displayed)


One last question
How to a create a border around the Text Box? the option does not seem available.

Hello @Bruce_X

You can add one more condition to the logic for the result block and display the value that you need.

In the case when the result displays “00”, you need to check your logic, since I checked the result in my application and it is displayed valid

You cannot add a border to a text block, but you can place a text block in a regular block and adjust the stroke for a regular block.


Hi Inna

Putting in the extra elseif worked brilliantly.