Support Topics Documentation Slack YouTube Blog

Import JSON imported to File instead of Data

Hello,

I’m trying to import a data JSON into a table and the file save in files instead of updating the table.

I tried to import the same JSON file that I imported a few days ago without problem an it is not possible. Normally, when I import a JSON file, the new datas appear immediately on the table.

Thank you.

Regards,
Alex.

Hi Alex

What do you mean when say “import a JSON file into a table” ?

do you mean you’ve got a table which has a FileReference column?

Regards, Vlad

I mean import data from a JSON file, sorry for the confusion.

I have a table named “MusicChannels_final” and I import a JSON with the same name “MusicChannels_final.json” and I use Import-Data Service and, instead to add the new rows to the table, the JSON file appear in Files/Import.

Regards,
Alex.

please provide your AppId

Appid: 4536768D-A16C-51A2-FFD8-88F38C76FD00

your json file in fact is not a json file it contains csv, so rename it to MusicChannels_final.csv,

but it should not be an issue, I just downloaded your MusicChannels_final.json file and imported it into my app without any problems

could you try to import the file again

Regards, Vlad

That’s true, it contains csv.

I have just imported the file again and now it worked.

Maybe I was doing something wrong,…anyway, thank you very much for all.

Regards,
Alex.